summaryrefslogtreecommitdiffstats
path: root/main/libxext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxext/APKBUILD')
-rw-r--r--main/libxext/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/libxext/APKBUILD b/main/libxext/APKBUILD
new file mode 100644
index 00000000000..dbfb1b26da3
--- /dev/null
+++ b/main/libxext/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxext
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="X11 miscellaneous extensions library"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends=
+makedepends="pkgconfig xproto xextproto libx11-dev libxau-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://xorg.freedesktop.org/releases/individual/lib/libXext-$pkgver.tar.bz2"
+
+depends_dev="xextproto libx11-dev libxau-dev"
+build() {
+ cd "$srcdir"/libXext-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir"/libXext-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="c417c0e8df39a067f90a2a2e7133637d libXext-1.1.1.tar.bz2"