aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxext/APKBUILD')
-rw-r--r--main/libxext/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/main/libxext/APKBUILD b/main/libxext/APKBUILD
index b811247bdbc..e953421741f 100644
--- a/main/libxext/APKBUILD
+++ b/main/libxext/APKBUILD
@@ -1,36 +1,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxext
-pkgver=1.3.4
-pkgrel=0
+pkgver=1.3.6
+pkgrel=2
pkgdesc="X11 miscellaneous extensions library"
-url="http://xorg.freedesktop.org/"
+url="https://xorg.freedesktop.org/"
arch="all"
license="MIT"
-depends=
depends_dev="libxau-dev"
makedepends="$depends_dev libx11-dev xorgproto util-macros xmlto"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
options="!check"
-source="https://www.x.org/releases/individual/lib/libXext-$pkgver.tar.bz2
+source="https://www.x.org/releases/individual/lib/libXext-$pkgver.tar.xz
"
builddir="$srcdir"/libXext-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
+ --enable-static \
--with-xmlto \
--without-fop
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="09146397d95f80c04701be1cc0a9c580ab5a085842ac31d17dfb6d4c2e42b4253b89cba695e54444e520be359883a76ffd02f42484c9e2ba2c33a5a40c29df4a libXext-1.3.4.tar.bz2"
+sha512sums="
+fd7693b5698cc4f5e80002a2cd4bd88e5d52c755c19a0417ee73029bd65f9d77b0969e765a1febc4d8fce1ba5dfb7278717f47be742e33d8fc5eb941e769792e libXext-1.3.6.tar.xz
+"