summaryrefslogtreecommitdiffstats
path: root/main/libxml2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxml2/APKBUILD')
-rw-r--r--main/libxml2/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/main/libxml2/APKBUILD b/main/libxml2/APKBUILD
index 01959c31967..145ed220598 100644
--- a/main/libxml2/APKBUILD
+++ b/main/libxml2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=libxml2
pkgver=2.7.8
-pkgrel=5
+pkgrel=6
pkgdesc="XML parsing library, version 2"
url="http://www.xmlsoft.org/"
arch="all"
@@ -26,6 +26,7 @@ source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
libxml2-2.7.8-entities-local-buffers-size2.patch
libxml2-2.7.8-parser-local-buffers-size.patch
CVE-2012-5134.patch
+ CVE-2013-0338.patch
"
options="!strip"
@@ -33,8 +34,10 @@ options="!strip"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
- for _i in "$srcdir"/*.patch; do
- patch -p1 -i "$_i"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
}
@@ -80,4 +83,5 @@ de02f584b928d3e25babc5c90aa800be libxml2-2.7.8-allocation-error-copying-entitie
c8c789a4fbdae599a47ecbfa32b889d7 libxml2-2.7.8-entities-local-buffers-size.patch
cba1201e77dc0f3e337d9ff146a2666e libxml2-2.7.8-entities-local-buffers-size2.patch
6c5c7a125dddb616feb1b2f4254bf467 libxml2-2.7.8-parser-local-buffers-size.patch
-fe428448d74481d7547bc173cb40ef26 CVE-2012-5134.patch"
+fe428448d74481d7547bc173cb40ef26 CVE-2012-5134.patch
+5eb19e0b5107a9ee6cca8a5f04b44b77 CVE-2013-0338.patch"