aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxpm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libxpm/APKBUILD')
-rw-r--r--main/libxpm/APKBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/main/libxpm/APKBUILD b/main/libxpm/APKBUILD
index de514b92ac3..7f5a14efb63 100644
--- a/main/libxpm/APKBUILD
+++ b/main/libxpm/APKBUILD
@@ -1,25 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxpm
-pkgver=3.5.13
+pkgver=3.5.17
pkgrel=0
pkgdesc="X11 pixmap library"
-url="http://xorg.freedesktop.org/"
+url="https://xorg.freedesktop.org/"
arch="all"
-license="custom:BELL"
+license="X11"
options="!check" # No test suite.
subpackages="$pkgname-dev $pkgname-doc"
makedepends="libxt-dev libxext-dev util-linux-dev util-macros"
-source="https://www.x.org/releases/individual/lib/libXpm-$pkgver.tar.bz2"
-
+source="https://www.x.org/releases/individual/lib/libXpm-$pkgver.tar.xz"
builddir="$srcdir"/libXpm-$pkgver
+# secfixes:
+# 3.5.17-r0:
+# - CVE-2023-43788
+# - CVE-2023-43789
+# 3.5.15-r0:
+# - CVE-2022-46285
+# - CVE-2022-44617
+# - CVE-2022-4883
+
build() {
ac_cv_search_gettext=no \
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ --disable-open-zfile
make
}
@@ -27,4 +36,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="3b8f6e926272f39b1d95135c2274c00f5aaee1f9fb2ef79f71628df5edeb7ba20158819ef6a778101cc4092493a3b5b613c53634fdccadcc0fc85f0605e5e9a5 libXpm-3.5.13.tar.bz2"
+
+sha512sums="
+52f9d2664a47a26c1a6ad65d18867de870b66947b0b0d99cca3512756a0aaa6ce2a245c0b49f20b70c3ce48bf04c47c333e8119a147465c277bca727f6ab017e libXpm-3.5.17.tar.xz
+"