aboutsummaryrefslogtreecommitdiffstats
path: root/main/lighttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lighttpd/APKBUILD')
-rw-r--r--main/lighttpd/APKBUILD86
1 files changed, 53 insertions, 33 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index d73fcfc7d56..9e82fd6f100 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
-pkgver=1.4.59
-pkgrel=2
+pkgver=1.4.76
+pkgrel=0
pkgdesc="Secure, fast, compliant and very flexible web-server"
url="https://www.lighttpd.net"
arch="all"
@@ -10,11 +10,27 @@ license="BSD-3-Clause"
install="$pkgname.pre-install $pkgname.pre-upgrade"
pkgusers="lighttpd"
pkggroups="lighttpd"
-makedepends="flex pcre-dev openssl1.1-compat-dev zlib-dev bzip2-dev lua5.3-dev
- automake autoconf openldap-dev libxml2-dev sqlite-dev libev-dev
- bsd-compat-headers"
-subpackages="$pkgname-doc $pkgname-dbg $pkgname-openrc $pkgname-mod_auth
- $pkgname-mod_webdav"
+makedepends="
+ brotli-dev
+ libdbi-dev
+ libxml2-dev
+ lua5.4-dev
+ meson
+ openldap-dev
+ openssl-dev
+ pcre2-dev
+ sqlite-dev
+ zlib-dev
+ zstd-dev
+ "
+checkdepends="perl"
+subpackages="
+ $pkgname-dbg
+ $pkgname-doc
+ $pkgname-openrc
+ $pkgname-mod_auth
+ $pkgname-mod_webdav
+ "
source="https://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-$pkgver.tar.xz
$pkgname.initd
$pkgname.confd
@@ -23,35 +39,37 @@ source="https://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-$pkgver.t
mime-types.conf
mod_cgi.conf
mod_fastcgi.conf
- mod_fastcgi_fpm.conf"
+ mod_fastcgi_fpm.conf
+ "
+
+# secfixes:
+# 1.4.67-r0:
+# - CVE-2022-41556
+# 1.4.64-r0:
+# - CVE-2022-22707
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-dependency-tracking \
- --enable-lfs \
- --libdir=/usr/lib/lighttpd \
- --without-mysql \
- --without-attr \
- --with-webdav-props \
- --with-webdav-locks \
- --without-gdbm \
- --with-bzip2 \
- --with-ldap \
- --with-openssl \
- --with-libev \
- --with-lua
- make
+ abuild-meson \
+ -Db_lto=true \
+ -Dwith_brotli=enabled \
+ -Dwith_dbi=enabled \
+ -Dwith_ldap=enabled \
+ -Dwith_lua=true \
+ -Dwith_openssl=true \
+ -Dwith_pcre2=true \
+ -Dwith_webdav_locks=enabled \
+ -Dwith_webdav_props=enabled \
+ -Dwith_zstd=enabled \
+ . output
+ meson compile -C output
}
check() {
- make check
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
# create dirs
install -d -m2750 -o lighttpd -g wheel \
@@ -72,7 +90,7 @@ package() {
local i; for i in lighttpd.conf mime-types.conf mod_cgi.conf \
mod_fastcgi.conf mod_fastcgi_fpm.conf
do
- install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
+ install -Dm644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
done
}
@@ -95,12 +113,14 @@ mod_webdav() {
_mv_mod mod_webdav
}
-sha512sums="94d312f6ac65c32057018b749c4865220b43b3e4b7fe9396848aa403ea7fdc2ccbf3f4f91daf281b754cf272a52a8bcdc689502773ea33cae36eead2785daa0f lighttpd-1.4.59.tar.xz
-f2f3c5c7731550237fd75a8de66275f427eaf897cffff7ac7ef44178328ad8fad6c4ec6654759bfc665cbaf7991ddcdf0aaa916831c8b6aa440192d57b242038 lighttpd.initd
+sha512sums="
+940f00f2d84e3424c389108d09756a0af41db3559474135b6c502deccd08ad051b5184f3f7907436384964d2b05045e27dca463af98c889cee69b0ae6e202782 lighttpd-1.4.76.tar.xz
+a74fb8394fb77fca2a08bdcfc79d4e13de6aca7bc4ed842b7e05f7f3a9cc85dccaa4971ba8fd0edfaa19da8d3870a743b713d9e51f1cbfe5b8e2843bb7fe5346 lighttpd.initd
9d2ab5deb7353ebf290e90936b511941df440859c78589d0bcf130ef69a5e9c79e4d318548b6b118df002083c46f7476230a28954b7a10a9dbd05040e02b1291 lighttpd.confd
0536b4f21d2e8659f7831b45998c13d9f6051ae7ecde13be01f372f837d255bfc4e211de48a7686cc743d53aa9c08ab3f10ec19788896dcf8356b90053ca7a16 lighttpd.logrotate
-0aab94cb49ef5a96c1b5dbcf142b41acf49286ed6e2a252210f3f7fb6ee0639ebc5b8f4ddc89eb4b9a2bde38af07b8f008473aef2a460488ac806844f398350d lighttpd.conf
+37ff6ad319fbbe1f390098c7eecee8e292d5766af94533243e603c4918f41d702abe449eaed59455d2b65f13546f5fd1353ca6455aede5ce62ec1d77edaf9a97 lighttpd.conf
a3f2f5763885d7e4f510491b24164e34aaf62bb02daa12991575dc64335c12668355af5bb8d6ce191eb4e9cce95324b1f7c9ba61b323b4e7b50a1e03e021afcf mime-types.conf
27cc638d8068dcf47bd9db44943d1db6c6f4e8e6abd6b42af7cea004b1c093440068541d98c68f8bea70b956713adaf8ed59a4b642dea826ee8620a05f8cfde5 mod_cgi.conf
1d15b84c03fb648a0e67ab5c5411b85478b4454c44bc2959cc96d1700eeadd7ff429520a5f1550db6527267646622dccd3d47d3fd1258869fccaf5c22d4ad4b2 mod_fastcgi.conf
-f9efc4b70d825600f5356c30e57d0b6cac11c01739337f7192c09c2cfd96cb76c8328b11d818ea4c2addc1a6d253975b84700106ae75854d55d0df73e220bd2b mod_fastcgi_fpm.conf"
+f9efc4b70d825600f5356c30e57d0b6cac11c01739337f7192c09c2cfd96cb76c8328b11d818ea4c2addc1a6d253975b84700106ae75854d55d0df73e220bd2b mod_fastcgi_fpm.conf
+"