summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/linux-grsec/APKBUILD')
-rw-r--r--main/linux-grsec/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 72e5127e055..750aa0f3790 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.38.8
_kernver=2.6.38
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -69,6 +69,7 @@ menuconfig() {
build() {
cd "$srcdir"/build
+ export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
make CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
@@ -141,5 +142,5 @@ c0f416f6a2e916633f697287cc7cb914 patch-2.6.38.8.bz2
58e1f9194fa75df9afdf2746370fa3cb grsecurity-2.2.2-2.6.38.8-unofficial.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
aa1b82da0cabfb41c5e6da5bddf60bab net-gre-provide-multicast-mappings-for-ipv4-and-ipv6.patch
-f4cf5b0ddfeef7aa87fb27792aff88a4 kernelconfig.x86
+991a83798618ad3318502116a8044d99 kernelconfig.x86
0a73d8d896101de90f47dae32119e7ca kernelconfig.x86_64"