aboutsummaryrefslogtreecommitdiffstats
path: root/main/logcheck/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/logcheck/APKBUILD')
-rw-r--r--main/logcheck/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/logcheck/APKBUILD b/main/logcheck/APKBUILD
index 8dc7916bb4f..5d58df569a2 100644
--- a/main/logcheck/APKBUILD
+++ b/main/logcheck/APKBUILD
@@ -1,21 +1,24 @@
# Contributor: Duane Hughes <duanejevon@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=logcheck
-pkgver=1.3.23
+pkgver=1.4.3
pkgrel=0
pkgdesc="Bash scripts used to monitor system log files for anomalies"
options="!check" # Requires writing to root owned paths but can't run as root
-url="http://packages.debian.org/source/sid/logcheck"
+url="https://packages.debian.org/source/sid/logcheck"
arch="noarch"
license="GPL-2.0-or-later"
-depends="lockfile-progs"
+depends="
+ bash
+ lockfile-progs
+ perl
+ "
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
pkgusers="logcheck"
-source="http://ftp.debian.org/debian/pool/main/l/logcheck/logcheck_$pkgver.tar.xz
- logcheck.cron.d"
-
-builddir="$srcdir"/$pkgname
+source="https://deb.debian.org/debian/pool/main/l/logcheck/logcheck_$pkgver.tar.xz
+ logcheck.cron.d
+ "
package() {
make DESTDIR="$pkgdir" install
@@ -29,6 +32,6 @@ package() {
}
sha512sums="
-635a96c3e0beaf6056e5b96b3bd69134c3330308452e3bcf8cc28cb36365f07806046bf498cbfaf5cfbc38a812eb2723ddf51a16304140e8f7091f1e6005ec4d logcheck_1.3.23.tar.xz
+e6c3ef20b44e23099a6b9054f210c8baead6f6a6a84d2d2f0bc465ef95bdf9b267a85f59ec876d1854e0e76f1fb4263a30036caf84b4c8bff15763fb6f9ff6a2 logcheck_1.4.3.tar.xz
a177388f18c220323eea6f5413f76873e6ad2a2334f58a05727c7b94a793fcb98bd605cefc6fe44aca6afe5c50a9ef851abcc439aefe5b7545d5d6bb584c0a8b logcheck.cron.d
"