aboutsummaryrefslogtreecommitdiffstats
path: root/main/lsof/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lsof/APKBUILD')
-rw-r--r--main/lsof/APKBUILD33
1 files changed, 25 insertions, 8 deletions
diff --git a/main/lsof/APKBUILD b/main/lsof/APKBUILD
index 6d8400201e5..832bcd5c7fa 100644
--- a/main/lsof/APKBUILD
+++ b/main/lsof/APKBUILD
@@ -1,20 +1,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lsof
-pkgver=4.94.0
+pkgver=4.99.3
pkgrel=0
pkgdesc="LiSt Open Files"
url="https://github.com/lsof-org/lsof"
arch="all"
-license="lsof"
+license="custom"
subpackages="$pkgname-doc"
-makedepends="linux-headers"
-source="$pkgname-$pkgver.tar.gz::https://github.com/lsof-org/lsof/archive/$pkgver/lsof-$pkgver.tar.gz"
+makedepends="bash linux-headers perl"
+source="https://github.com/lsof-org/lsof/archive/$pkgver/lsof-$pkgver.tar.gz
+ hassecurity.patch
+ "
prepare() {
default_prepare
- sed -i "s|/\* #define\tHASSECURITY\t1 \*/|#define\tHASSECURITY\t1|" \
- dialects/linux/machine.h
+ # This test is skipped on other architectures where unshare
+ # returns "Operation not permitted", but on ppc64le unshare
+ # returns "Function not implemented" causing a fail instead
+ case "$CARCH" in
+ ppc64le)
+ rm -v lib/dialects/linux/tests/case-20-mmap.bash
+ ;;
+ esac
}
build() {
@@ -22,9 +30,18 @@ build() {
make
}
+check() {
+ (cd tests && ./Add2TestDB)
+ make check
+}
+
package() {
- install -Dm0755 lsof "$pkgdir"/usr/bin/lsof
+ install -Dm0755 lsof -t "$pkgdir"/usr/bin/
install -Dm0644 Lsof.8 "$pkgdir"/usr/share/man/man8/lsof.8
+ install -Dm0644 COPYING -t "$pkgdir"/usr/share/licenses/$pkgname/
}
-sha512sums="852b12e621e1dbf71e5f7fd848a200339ca278fbe8c39dcd33f745d1aea4e61552c0f30a3f6469ad9d4b86a9163e677f8c95298159ebd647357734225aa06c0c lsof-4.94.0.tar.gz"
+sha512sums="
+eed9cddecf93cf55e8106a0409d254feca8c5c40792d7dad4b34cbe7c9caec00b7a7b9526465362bf3448efef219fd6e309051455d20fd0945391e915a43bc93 lsof-4.99.3.tar.gz
+379c24df3bcad88bd35c2d9331064312e9faa0e6426479b3e3d3edd377860007ba3af2a0b4b0b998f0146bfd7d067dc4ee7d6f32a6f5e352afc875f6298ab1c2 hassecurity.patch
+"