aboutsummaryrefslogtreecommitdiffstats
path: root/main/lsyncd/fix-mandir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/lsyncd/fix-mandir.patch')
-rw-r--r--main/lsyncd/fix-mandir.patch14
1 files changed, 8 insertions, 6 deletions
diff --git a/main/lsyncd/fix-mandir.patch b/main/lsyncd/fix-mandir.patch
index 6eceefe36a3..e125ec5d684 100644
--- a/main/lsyncd/fix-mandir.patch
+++ b/main/lsyncd/fix-mandir.patch
@@ -1,9 +1,11 @@
---- ./CMakeLists.txt.orig
-+++ ./CMakeLists.txt
-@@ -107,5 +107,5 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -127,6 +127,6 @@
target_link_libraries( lsyncd ${LUA_LIBRARIES} )
install( TARGETS lsyncd RUNTIME DESTINATION bin )
--install( FILES doc/manpage/lsyncd.1 DESTINATION man )
-+install( FILES doc/manpage/lsyncd.1 DESTINATION share/man/man1 )
-
+-install( FILES docs/manpage/lsyncd.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 COMPONENT man )
++install( FILES docs/manpage/lsyncd.1 DESTINATION share/man/man1 COMPONENT man )
+-install( DIRECTORY examples DESTINATION doc )
++install( DIRECTORY examples DESTINATION share/doc )
+ install( DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION doc OPTIONAL)