aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-cmsgpack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-cmsgpack/APKBUILD')
-rw-r--r--main/lua-cmsgpack/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/main/lua-cmsgpack/APKBUILD b/main/lua-cmsgpack/APKBUILD
index 6fcc025b05d..007b9b888f3 100644
--- a/main/lua-cmsgpack/APKBUILD
+++ b/main/lua-cmsgpack/APKBUILD
@@ -2,26 +2,20 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lua-cmsgpack
pkgver=0.4.0
-pkgrel=0
+pkgrel=2
pkgdesc="MessagePack C implementation for Lua"
url="https://github.com/antirez/lua-cmsgpack"
arch="all"
license="BSD-2-Clause"
-depends=""
-depends_dev=""
makedepends="lua-dev"
-install=""
-subpackages=""
source="lua-cmsgpack-$pkgver.tar.gz::https://github.com/antirez/lua-cmsgpack/archive/$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
+options="!check"
build() {
- cd "$_builddir"
${CC:-gcc} $CFLAGS -fPIC $(pkg-config --cflags lua) -o cmsgpack.so -shared $LFDLAGS $(pkg-config --libs lua) lua_cmsgpack.c
}
package() {
- cd "$_builddir"
local dir=$( pkg-config --variable INSTALL_CMOD lua)
install -D cmsgpack.so "$pkgdir"/$dir/cmsgpack.so
}