aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-evdev/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-evdev/APKBUILD')
-rw-r--r--main/lua-evdev/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/main/lua-evdev/APKBUILD b/main/lua-evdev/APKBUILD
index 21824b16f29..e5082d43f4c 100644
--- a/main/lua-evdev/APKBUILD
+++ b/main/lua-evdev/APKBUILD
@@ -3,27 +3,26 @@ _luaversions="5.1 5.2 5.3"
pkgname=lua-evdev
_rockname=evdev
pkgver=2.2.1
-pkgrel=1
+pkgrel=3
pkgdesc="Lua module for reading input events"
url="https://github.com/Tangent128/lua-evdev"
arch="all"
license="MIT"
-depends=""
makedepends="linux-headers"
-subpackages=""
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_package"
done
-source="$pkgname-$pkgver.tar.gz::https://github.com/Tangent128/$pkgname/archive/evdev-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/Tangent128/lua-evdev/archive/evdev-$pkgver.tar.gz
time64.patch"
builddir="$srcdir/$pkgname-evdev-$pkgver"
+options="!check"
prepare() {
- default_prepare || return 1
+ default_prepare
local lver; for lver in $_luaversions; do
- cp -r "$builddir" "$builddir-$lver" || return 1
+ cp -r "$builddir" "$builddir-$lver"
done
}
@@ -32,7 +31,7 @@ build() {
msg "Building for Lua $lver..."
cd "$builddir-$lver"
- make MYCFLAGS="$CFLAGS $(pkg-config --cflags lua$lver)" || return 1
+ make MYCFLAGS="$CFLAGS $(pkg-config --cflags lua$lver)"
done
}
@@ -50,7 +49,7 @@ _package() {
cd "$builddir-$lver"
local f; for f in evdev.lua evdev/constants.lua; do
- install -D $f "$subpkgdir"/usr/share/lua/$lver/$f || return 1
+ install -D $f "$subpkgdir"/usr/share/lua/$lver/$f
done
install -D evdev/core.so "$subpkgdir"/usr/lib/lua/$lver/evdev/core.so