aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-penlight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-penlight/APKBUILD')
-rw-r--r--main/lua-penlight/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/main/lua-penlight/APKBUILD b/main/lua-penlight/APKBUILD
index d38a208c701..722f0a96c47 100644
--- a/main/lua-penlight/APKBUILD
+++ b/main/lua-penlight/APKBUILD
@@ -1,17 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua-penlight
_rockname=penlight
-pkgver=1.7.0
-pkgrel=2
+pkgver=1.14.0
+pkgrel=0
pkgdesc="Lua libraries for extended operations on tables, lists and strings"
-options="!check" # Requires lua-coveralls
-url="http://stevedonovan.github.io/Penlight"
+url="https://lunarmodules.github.io/Penlight/"
arch="noarch"
license="MIT"
depends="lua lua-filesystem"
-checkdepends="luajit"
subpackages="$pkgname-doc"
-source="$_rockname-$pkgver.tar.gz::https://github.com/stevedonovan/Penlight/archive/$pkgver.tar.gz"
+source="https://github.com/lunarmodules/Penlight/archive/$pkgver/lua-penlight-$pkgver.tar.gz"
builddir="$srcdir/Penlight-$pkgver"
provides="$pkgname-shared=$pkgver-r$pkgrel" # for backward compatibility
@@ -23,8 +21,17 @@ for _v in $_luaversions; do
subpackages="$subpackages lua$_v-penlight:_split"
done
+case "$CARCH" in
+ppc64le|riscv64|loongarch64)
+ ;;
+*)
+ checkdepends="$checkdepends luajit"
+ _luaversions="$_luaversions jit"
+ ;;
+esac
+
check() {
- local lver; for lver in $_luaversions jit; do
+ local lver; for lver in $_luaversions; do
msg "Testing on Lua $lver"
lua$lver run.lua tests
done
@@ -55,4 +62,6 @@ _split() {
ln -s ../common/pl "$subpkgdir"/usr/share/lua/$_ver/pl
}
-sha512sums="edeb09307c9feb5da6bccd82216a6ad71db988c433245d72d28abb6c555004f77eebba556928b0912937b29ef93e065ad491368041e17730610813de8e595d7d penlight-1.7.0.tar.gz"
+sha512sums="
+a83f70716106d6576b27a42222ba897d5d5a7b3918088c582e89283cf091a95a9920fe6d0b8d65e1ffc4c1664166f7d5bc4df3b023539d1b33d7175e585bbe9f lua-penlight-1.14.0.tar.gz
+"