aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-penlight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-penlight/APKBUILD')
-rw-r--r--main/lua-penlight/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/lua-penlight/APKBUILD b/main/lua-penlight/APKBUILD
index 7ed180dc79f..d38a208c701 100644
--- a/main/lua-penlight/APKBUILD
+++ b/main/lua-penlight/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lua-penlight
_rockname=penlight
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Lua libraries for extended operations on tables, lists and strings"
options="!check" # Requires lua-coveralls
url="http://stevedonovan.github.io/Penlight"
@@ -17,7 +17,7 @@ builddir="$srcdir/Penlight-$pkgver"
provides="$pkgname-shared=$pkgver-r$pkgrel" # for backward compatibility
replaces="$pkgname-shared" # for backward compatibility
-_luaversions="5.1 5.2 5.3"
+_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
checkdepends="$checkdepends lua$_v"
subpackages="$subpackages lua$_v-penlight:_split"
@@ -47,7 +47,7 @@ _split() {
local _lua=${subpkgname%%-*}
local _ver=${_lua#lua}
pkgdesc="Lua $—ver libraries for extended operations on tables, lists and strings"
- depends="${_lua}-filesystem"
+ depends="$_lua-filesystem"
mkdir -p "$subpkgdir"/usr/share/lua/$_ver
# keep this so abuild pulls in the right dependency with the common