aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-penlight/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-penlight/APKBUILD')
-rw-r--r--main/lua-penlight/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/main/lua-penlight/APKBUILD b/main/lua-penlight/APKBUILD
index 2863b952006..7ed180dc79f 100644
--- a/main/lua-penlight/APKBUILD
+++ b/main/lua-penlight/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lua-penlight
_rockname=penlight
pkgver=1.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Lua libraries for extended operations on tables, lists and strings"
options="!check" # Requires lua-coveralls
url="http://stevedonovan.github.io/Penlight"
@@ -20,7 +20,7 @@ replaces="$pkgname-shared" # for backward compatibility
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
checkdepends="$checkdepends lua$_v"
- provides="$provides lua$_v-${pkgname#lua-}=$pkgver-r$pkgrel" # for backward compatibility
+ subpackages="$subpackages lua$_v-penlight:_split"
done
check() {
@@ -43,4 +43,16 @@ package() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
+_split() {
+ local _lua=${subpkgname%%-*}
+ local _ver=${_lua#lua}
+ pkgdesc="Lua $—ver libraries for extended operations on tables, lists and strings"
+ depends="${_lua}-filesystem"
+ mkdir -p "$subpkgdir"/usr/share/lua/$_ver
+
+ # keep this so abuild pulls in the right dependency with the common
+ # files
+ ln -s ../common/pl "$subpkgdir"/usr/share/lua/$_ver/pl
+}
+
sha512sums="edeb09307c9feb5da6bccd82216a6ad71db988c433245d72d28abb6c555004f77eebba556928b0912937b29ef93e065ad491368041e17730610813de8e595d7d penlight-1.7.0.tar.gz"