aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-resty-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-resty-core/APKBUILD')
-rw-r--r--main/lua-resty-core/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/lua-resty-core/APKBUILD b/main/lua-resty-core/APKBUILD
index 0147c6455e3..53ea84bbbe0 100644
--- a/main/lua-resty-core/APKBUILD
+++ b/main/lua-resty-core/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
pkgname=lua-resty-core
-pkgver=0.1.21
+pkgver=0.1.28
pkgrel=0
pkgdesc="New FFI-based API for lua-nginx-module"
url="https://github.com/openresty/lua-resty-core"
-arch="noarch !riscv64"
+# luajit
+arch="noarch !ppc64le !riscv64"
license="BSD-2-Clause"
depends="luajit lua-resty-lrucache"
-source="https://github.com/openresty/lua-resty-core/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/openresty/lua-resty-core/archive/v$pkgver/lua-resty-core-$pkgver.tar.gz"
options="!check" # FIXME: tests require OpenResty and additional dependencies
package() {
@@ -19,4 +20,6 @@ package() {
"$pkgdir"/usr/lib/luarocks/rocks-common/$pkgname/$pkgver-1
}
-sha512sums="e34475fe3966493d010dd0e6e9d0073e6cd6e700ccf34048b6ac26af52206333b12500c755f29904fd5d792556d26d19f0ddfd3b61cd9f5e0dc608bef17051a5 lua-resty-core-0.1.21.tar.gz"
+sha512sums="
+0f54f6eec0805ce31091ce11b065b98a3b286ca3523f5eaf8a85bd8ba229c362a90fa464d5b4b68f155b06011ebb071115e16fd35aa3dd33e316e84a7ec43593 lua-resty-core-0.1.28.tar.gz
+"