aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-resty-lrucache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-resty-lrucache/APKBUILD')
-rw-r--r--main/lua-resty-lrucache/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/lua-resty-lrucache/APKBUILD b/main/lua-resty-lrucache/APKBUILD
index eb042ef6581..a1deb5d8b31 100644
--- a/main/lua-resty-lrucache/APKBUILD
+++ b/main/lua-resty-lrucache/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
pkgname=lua-resty-lrucache
-pkgver=0.09
+pkgver=0.13
pkgrel=1
pkgdesc="Lua-land LRU Cache based on LuaJIT FFI"
url="https://github.com/openresty/lua-resty-lrucache"
-arch="noarch !riscv64"
+# luajit
+arch="noarch !ppc64le !riscv64 !loongarch64"
license="BSD-2-Clause"
depends="luajit"
-source="https://github.com/openresty/lua-resty-lrucache/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver-2.tar.gz::https://github.com/openresty/lua-resty-lrucache/archive/v$pkgver/lua-resty-lrucache-$pkgver.tar.gz"
options="!check" # FIXME: tests require OpenResty and additional dependencies
package() {
@@ -19,4 +20,6 @@ package() {
"$pkgdir"/usr/lib/luarocks/rocks-common/$pkgname/$pkgver-1
}
-sha512sums="0042f5459a5d994ad3837ceeba7884efe85d2ab7194c8b08d026418c7c81c948ae1de91628d29afde45dae44f326fc5fb295988f24e95e5398a52014af50e3e2 lua-resty-lrucache-0.09.tar.gz"
+sha512sums="
+d6491acdca5d7b02feef1bf7fafb31798ae3194ad759a9ba87e895ef4e71268a2785291504f73e07e6872bed0d30147ca5e2cd0a0250db11f0a361af43426dfe lua-resty-lrucache-0.13-2.tar.gz
+"