aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-xctrl/fix-linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-xctrl/fix-linking.patch')
-rw-r--r--main/lua-xctrl/fix-linking.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/main/lua-xctrl/fix-linking.patch b/main/lua-xctrl/fix-linking.patch
new file mode 100644
index 00000000000..682b85f1e11
--- /dev/null
+++ b/main/lua-xctrl/fix-linking.patch
@@ -0,0 +1,16 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -33,11 +33,11 @@
+ lib: $(LIBNAME)_clean $(LIBNAME)
+
+ $(LIBNAME): xctrl.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared $^ -o $@
++ $(CC) $(CFLAGS) -shared $^ -o $@ $(LDFLAGS)
+
+
+ $(MODNAME): lxctrl.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared $^ -o $@
++ $(CC) $(CFLAGS) -shared $^ -o $@ $(LDFLAGS)
+
+
+ %.o: %.c