aboutsummaryrefslogtreecommitdiffstats
path: root/main/lucene++/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lucene++/APKBUILD')
-rw-r--r--main/lucene++/APKBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/main/lucene++/APKBUILD b/main/lucene++/APKBUILD
deleted file mode 100644
index 3ba87b28e61..00000000000
--- a/main/lucene++/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=lucene++
-pkgver=3.0.7
-pkgrel=10
-pkgdesc="C++ port of the popular Java Lucene library"
-url="https://github.com/luceneplusplus/LucenePlusPlus"
-arch="all"
-license="LGPL-3.0-or-later Apache-2.0"
-depends=""
-depends_dev="boost-dev"
-makedepends="$depends_dev cmake linux-headers"
-install=""
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
-
-builddir="$srcdir/LucenePlusPlus-rel_$pkgver"
-
-build() {
- mkdir "$builddir"/build
- cd "$builddir"/build
- cmake \
- -DCMAKE_BUILD_TYPE:String="release" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_DESTINATION=/usr/lib \
- -DBoost_LIBRARY_DIR=/usr/lib \
- -DENABLE_CUSTOM_ALLOCATOR='FALSE' \
- -DCMAKE_CXX_FLAGS='-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT' \
- -DCOTIRE_ADDITIONAL_PREFIX_HEADER_IGNORE_PATH='/usr/include/fortify' \
- ..
- make
-}
-
-package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="92f3bba320980673cc64c983616aa38d25b44ea811237ed226741b892757fb8151e4f833aa58a18dbe7a0c9a899d94e828aa15e6d7b48a69ab730d1d772db220 lucene++-3.0.7.tar.gz"