aboutsummaryrefslogtreecommitdiffstats
path: root/main/lz4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lz4/APKBUILD')
-rw-r--r--main/lz4/APKBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/main/lz4/APKBUILD b/main/lz4/APKBUILD
index e7a0edc282d..69e849355ad 100644
--- a/main/lz4/APKBUILD
+++ b/main/lz4/APKBUILD
@@ -1,17 +1,15 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=lz4
-pkgver=1.9.3
-pkgrel=1
+pkgver=1.9.4
+pkgrel=5
pkgdesc="LZ4 is lossless compression algorithm with fast decoder @ multiple GB/s per core."
url="https://github.com/lz4/lz4"
arch="all"
-license="BSD-2-Clause GPL-2.0-only"
+license="BSD-2-Clause AND GPL-2.0-only"
checkdepends="diffutils"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-libs $pkgname-tests:tests"
-source="$pkgname-$pkgver.tar.gz::https://github.com/lz4/lz4/archive/v$pkgver.tar.gz
- CVE-2021-3520.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/lz4/lz4/archive/v$pkgver.tar.gz"
# secfixes:
# 1.9.3-r1:
@@ -20,26 +18,31 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/lz4/lz4/archive/v$pkgver.tar
# - CVE-2019-17543
build() {
+ export CFLAGS="$CFLAGS -O2 -flto=auto"
+ export CPPFLAGS="$CPPFLAGS -O2 -flto=auto"
make PREFIX="/usr"
}
check() {
- # https://github.com/lz4/lz4/issues/957
- make -j1 check
-}
-
-tests() {
- cd "$builddir"/tests
- mkdir -p "$subpkgdir"/usr/share/$pkgname
- rm -f *.c COPYING Makefile .gitignore
- cp -rf "$builddir"/tests "$subpkgdir"/usr/share/$pkgname
+ make check
}
package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
+
+ (
+ cd tests/
+ rm -f ./*.c COPYING Makefile .gitignore
+ )
+ mkdir -p "$pkgdir"/usr/share/$pkgname
+ cp -rf tests "$pkgdir"/usr/share/$pkgname/
+}
+
+tests() {
+ pkgdesc="$pkgdesc (tests)"
+ amove usr/share/$pkgname
}
sha512sums="
-c246b0bda881ee9399fa1be490fa39f43b291bb1d9db72dba8a85db1a50aad416a97e9b300eee3d2a4203c2bd88bda2762e81bc229c3aa409ad217eb306a454c lz4-1.9.3.tar.gz
-29038d80c4399ded52b49e69d0f0d80bef8bf424e3540de366ef539706c8c1119784d6137c96130f131239d74a4c110dd9790cae5c9b17c102820446582c5637 CVE-2021-3520.patch
+043a9acb2417624019d73db140d83b80f1d7c43a6fd5be839193d68df8fd0b3f610d7ed4d628c2a9184f7cde9a0fd1ba9d075d8251298e3eb4b3a77f52736684 lz4-1.9.4.tar.gz
"