aboutsummaryrefslogtreecommitdiffstats
path: root/main/mandoc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mandoc/APKBUILD')
-rw-r--r--main/mandoc/APKBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/main/mandoc/APKBUILD b/main/mandoc/APKBUILD
index ff5755e5838..5f88c7658e8 100644
--- a/main/mandoc/APKBUILD
+++ b/main/mandoc/APKBUILD
@@ -3,23 +3,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mandoc
pkgver=1.14.6
-pkgrel=2
+pkgrel=13
pkgdesc="mandoc (formerly mdocml) UNIX manpage compiler toolset"
url="https://mandoc.bsd.lv/"
arch="all"
-license="ISC and BSD-2-Clause and BSD-3-Clause"
+license="ISC"
makedepends="zlib-dev"
checkdepends="perl"
-install="$pkgname.post-deinstall"
+install="$pkgname-apropos.post-deinstall"
triggers="$pkgname-apropos.trigger=/usr/share/man/*"
replaces="mdocml"
-provides="mdocml=$pkgver-r$pkgrel"
subpackages="$pkgname-doc $pkgname-dev $pkgname-apropos $pkgname-soelim"
source="https://mandoc.bsd.lv/snapshots/mandoc-$pkgver.tar.gz
+ dynamic-tagfile-support.patch
shared-libmandoc.patch
outdated-warn-disable.patch
"
+# higher than community/man-db for this
+provides="doc-provider mdocml=$pkgver-r$pkgrel"
+provider_priority=100
+
prepare() {
default_prepare
@@ -32,7 +36,6 @@ prepare() {
MANPATH_DEFAULT="/usr/share/man:/usr/local/man:/usr/local/share/man"
MANPATH_BASE="/usr/share/man"
LN="ln -sf"
- HAVE_LESS_T=0
__EOF__
}
@@ -51,24 +54,18 @@ package() {
apropos() {
pkgdesc="makewhatis/whatis and apropos tools and index"
- mkdir -p "$subpkgdir"/usr/sbin "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/apropos \
- "$pkgdir"/usr/bin/whatis \
- "$subpkgdir"/usr/bin/
- mv "$pkgdir"/usr/sbin/makewhatis \
- "$subpkgdir"/usr/sbin/
+ amove usr/bin/apropos usr/bin/whatis usr/sbin/makewhatis
}
soelim() {
pkgdesc="so elimination tool"
depends=""
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/soelim \
- "$subpkgdir"/usr/bin/
+ amove usr/bin/soelim
}
sha512sums="
54286070812a47b629f68757046d3c9a1bdd2b5d1c3b84a5c8e4cb92f1331afa745443f7238175835d8cfbe5b8dd442e00c75c3a5b5b8f8efd8d2ec8f636dad4 mandoc-1.14.6.tar.gz
+d84afd0f462dc3c00753f3db5b2690d8f0954b51f5b679667a75f8ea34cb3d2e961d732218b8c1c3a39c209df70ab273b583c4899c56482e7f8761c4b9fea02c dynamic-tagfile-support.patch
b512bcb8bae11853a3006e2122d7e652806d4bf2234638d8809fd823375b5b0bd590f7d6a90412baffcc3b7b6a0f197a10986728a70f24fe628f91bfb651d266 shared-libmandoc.patch
6eda39920cccb1238b104bb90ac4be2c32883897c72363560d8d39345819cdeff535680e78396052b2b8f981e169ad9b3c30da724def80a1501785d82ce7fa25 outdated-warn-disable.patch
"