aboutsummaryrefslogtreecommitdiffstats
path: root/main/mini_httpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mini_httpd/APKBUILD')
-rw-r--r--main/mini_httpd/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/main/mini_httpd/APKBUILD b/main/mini_httpd/APKBUILD
index 42d90d91970..33679d51864 100644
--- a/main/mini_httpd/APKBUILD
+++ b/main/mini_httpd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mini_httpd
pkgver=1.30
-pkgrel=3
+pkgrel=5
pkgdesc="Small forking webserver with ssl and ipv6 support"
url="http://www.acme.com/software/mini_httpd/"
arch="all"
@@ -10,17 +10,15 @@ pkgusers="minihttpd"
pkggroups="www-data"
# no tests/check provided by upstream
options="!check"
-makedepends="openssl1.1-compat-dev"
+makedepends="openssl-dev>3"
subpackages="$pkgname-doc $pkgname-openrc"
install="$pkgname.pre-install"
-source="http://www.acme.com/software/$pkgname/$pkgname-$pkgver.tar.gz
+source="http://www.acme.com/software/mini_httpd/mini_httpd-$pkgver.tar.gz
$pkgname.conf
$pkgname.initd
$pkgname.logrotate
cgi.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
-
# secfixes:
# 1.30-r0:
# - CVE-2018-18778
@@ -28,14 +26,12 @@ builddir="$srcdir/$pkgname-$pkgver"
# - CVE-2017-17663
build() {
- cd "$builddir"
- make CFLAGS="${CFLAGS} -DUSE_SSL" \
- LDFLAGS="${LDFLAGS}" \
+ make CFLAGS="$CFLAGS -DUSE_SSL" \
+ LDFLAGS="$LDFLAGS" \
SSL_LIBS="-lssl -lcrypto"
}
package() {
- cd "$builddir"
# does not respect DESTDIR
make install \
BINDIR="$pkgdir"/usr/sbin \