aboutsummaryrefslogtreecommitdiffstats
path: root/main/mousepad/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mousepad/APKBUILD')
-rw-r--r--main/mousepad/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/main/mousepad/APKBUILD b/main/mousepad/APKBUILD
index ecbbfd4275e..617fff6c024 100644
--- a/main/mousepad/APKBUILD
+++ b/main/mousepad/APKBUILD
@@ -1,20 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mousepad
pkgver=0.3.0
-pkgrel=0
-pkgdesc="Simple Text Editor for Xfce4 (based on Gedit)"
+pkgrel=1
+pkgdesc="Simple Text Editor for Xfce4"
url="http://foo-projects.org/~benny/xfce/apps.html"
arch="all"
-license="GPL-2"
+license="GPL2+"
makedepends="libxfcegui4-dev gtksourceview-dev"
depends="desktop-file-utils"
+install=""
subpackages="$pkgname-lang"
-install=
-source="http://archive.xfce.org/src/apps/mousepad/${pkgver%.*}/mousepad-$pkgver.tar.bz2"
+source="http://archive.xfce.org/src/apps/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+build () {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,7 +28,10 @@ build ()
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
+
md5sums="dcfcdfaa8a19c89f35d5f6f64753e6e1 mousepad-0.3.0.tar.bz2"
+sha256sums="10f27506994d0d0b8f9e02555404a144babedab97517abe3b6be8b2d21ff046d mousepad-0.3.0.tar.bz2"
+sha512sums="4e8f7cd8f05265c7f3964f0f5196721136c501351aa8c7bae1e3a6056fcd61f40364f2bb226817d458afa3707334dd600efbae2f8d050d65841ef03085717e42 mousepad-0.3.0.tar.bz2"