summaryrefslogtreecommitdiffstats
path: root/main/mpg123/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mpg123/APKBUILD')
-rw-r--r--main/mpg123/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/mpg123/APKBUILD b/main/mpg123/APKBUILD
new file mode 100644
index 00000000000..4a13dea81a1
--- /dev/null
+++ b/main/mpg123/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mpg123
+pkgver=1.8.1
+pkgrel=0
+pkgdesc="A console based real time MPEG Audio Player for Layer 1, 2 and 3"
+url="http://sourceforge.net/projects/mpg123"
+license="GPL2 LGPL2"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig libtool alsa-lib-dev"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-dependency-tracking \
+ --with-ipv6 \
+ --with-pic \
+ --with-optimization=0 \
+ --with-cpu=i386_fpu \
+ --with-audio="alsa oss" || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="856893f14b29b1cddf4aba32469860b4 mpg123-1.8.1.tar.bz2"