aboutsummaryrefslogtreecommitdiffstats
path: root/main/mpg123/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mpg123/APKBUILD')
-rw-r--r--main/mpg123/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/mpg123/APKBUILD b/main/mpg123/APKBUILD
index aa3f5ce599a..90e1d25fbb1 100644
--- a/main/mpg123/APKBUILD
+++ b/main/mpg123/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpg123
-pkgver=1.29.0
+pkgver=1.32.6
pkgrel=0
pkgdesc="Console-based MPEG Audio Player for Layers 1, 2 and 3"
options="libtool"
@@ -13,6 +13,7 @@ makedepends="libtool alsa-lib-dev linux-headers"
source="https://www.mpg123.org/download/mpg123-$pkgver.tar.bz2"
build() {
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,9 +31,11 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" install
+ # Installation is not parallel friendly and will fail
+ # sometimes
+ make -j1 DESTDIR="$pkgdir" install
}
sha512sums="
-4261a086395f118f6723d8a3757ebcf5244359be07af634d8bf802e48524978a0974f8b17b423bbf38d262c82ac9e31e0fd5d07a735f63f5e33f58d82dc5fdaf mpg123-1.29.0.tar.bz2
+a8f2833cd5b7568b96467917146d16dec7dbde527ba51b5f97b9f8093bbccab232803263f13a790b60ef36c9630d4277adaea41dac7dfd14052bf0be6620736b mpg123-1.32.6.tar.bz2
"