aboutsummaryrefslogtreecommitdiffstats
path: root/main/multipath-tools/0001-OPTFLAGS-patch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/multipath-tools/0001-OPTFLAGS-patch.patch')
-rw-r--r--main/multipath-tools/0001-OPTFLAGS-patch.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/multipath-tools/0001-OPTFLAGS-patch.patch b/main/multipath-tools/0001-OPTFLAGS-patch.patch
new file mode 100644
index 00000000000..0e7e0db06c5
--- /dev/null
+++ b/main/multipath-tools/0001-OPTFLAGS-patch.patch
@@ -0,0 +1,26 @@
+From c42ef66d93ad183a832c9c62a4c909a4cff27358 Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Thu, 7 May 2020 07:39:30 +0000
+Subject: [PATCH] OPTFLAGS patch
+
+Remove Werror and O2
+---
+ Makefile.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.inc b/Makefile.inc
+index d4d1e0d..fa39f25 100644
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -93,7 +93,7 @@ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
+ ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
+ WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered,)
+
+-OPTFLAGS = -O2 -g -pipe -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
++OPTFLAGS = -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Werror=format-security \
+ $(WNOCLOBBERED) \
+ -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) \
+--
+2.26.0
+