aboutsummaryrefslogtreecommitdiffstats
path: root/main/newt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/newt/APKBUILD')
-rw-r--r--main/newt/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/main/newt/APKBUILD b/main/newt/APKBUILD
index ebfaf9d844b..fbd5b982cac 100644
--- a/main/newt/APKBUILD
+++ b/main/newt/APKBUILD
@@ -1,28 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=newt
-pkgver=0.52.21
-pkgrel=2
+pkgver=0.52.24
+pkgrel=1
pkgdesc="Redhat's Newt windowing toolkit development files"
options="!check" # No testsuite
url="https://pagure.io/newt/"
arch="all"
-license="LGPL-2.0"
+license="LGPL-2.0-only"
makedepends="slang-dev popt-dev python3-dev ncurses-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py3-$pkgname:py3"
-source="https://releases.pagure.org/newt/newt-$pkgver.tar.gz
- fix-includes.patch
- "
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://releases.pagure.org/newt/newt-$pkgver.tar.gz"
prepare() {
- cd "$builddir"
+ default_prepare
+
sed -i -e 's:-lslang:-lslang -lncurses:g' \
-e 's:instroot:DESTDIR:g' Makefile.in
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,7 +29,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" prefix="/usr" RPM_OPT_FLAGS="ERROR" install
rm -f "$pkgdir"/usr/lib/*.a
}
@@ -44,5 +39,6 @@ py3() {
amove '/usr/lib/python*'
}
-sha512sums="d53d927996d17223e688bf54dccfabb2a3dc02bfe38ffc455964e86feaca3cd9f9ab5b19774433be430fa4d761cd9b6680b558f297acb86f80daeb6942f7d23c newt-0.52.21.tar.gz
-ce53446eb587b79790f12f806f02999568cb49067520813ab146d1f16c71f009e86ab72d08666e483b550fdae3332b673935b8aa1a14b02f5273217fb5404611 fix-includes.patch"
+sha512sums="
+2001f45fb1cdb48cbc51feb8b6e555a2e50b65d897db2dbc1b1711c04efb51834801bef921c89879ddb43de221a243ed240c4a3355eebafa78f50f24432acdcd newt-0.52.24.tar.gz
+"