aboutsummaryrefslogtreecommitdiffstats
path: root/main/nghttp2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nghttp2/APKBUILD')
-rw-r--r--main/nghttp2/APKBUILD60
1 files changed, 31 insertions, 29 deletions
diff --git a/main/nghttp2/APKBUILD b/main/nghttp2/APKBUILD
index b9580050798..59cc0f01147 100644
--- a/main/nghttp2/APKBUILD
+++ b/main/nghttp2/APKBUILD
@@ -1,23 +1,20 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
-pkgver=1.44.0
+pkgver=1.61.0
pkgrel=0
-pkgdesc="Experimental HTTP/2 client, server and proxy"
+pkgdesc="HTTP/2 C client, server and proxy"
url="https://nghttp2.org"
arch="all"
license="MIT"
-makedepends_build="autoconf automake libtool"
-makedepends_host="libev-dev openssl-dev zlib-dev c-ares-dev cunit-dev"
+makedepends_host="libev-dev openssl-dev>3 zlib-dev c-ares-dev"
+checkdepends="cunit-dev"
subpackages="$pkgname-static $pkgname-doc $pkgname-dev $pkgname-libs"
-source="https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz
- remove-mruby-tests.patch
- disable-failing-musl-unittest.patch
- "
-# temp allow textrels on riscv64
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
+source="https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
# secfixes:
+# 1.57.0-r0:
+# - CVE-2023-44487
# 1.41.0-r0:
# - CVE-2020-11080
# 1.39.2-r0:
@@ -35,7 +32,12 @@ check() {
}
build() {
- autoreconf -vif
+ if [ -z "$BOOTSTRAP" ]; then
+ # fat to keep static non-lto too for non-gcc
+ # -20% size
+ export CFLAGS="$CFLAGS -ffat-lto-objects -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -ffat-lto-objects -flto=auto"
+ fi
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,13 +46,25 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --without-libxml2 \
- --without-neverbleed \
- --without-jemalloc \
- --disable-python-bindings \
--disable-examples \
+ --disable-http3 \
+ --disable-werror \
+ --enable-app \
--enable-static \
- --enable-app
+ --enable-threads \
+ --with-libcares \
+ --with-libev \
+ --with-openssl \
+ --without-jansson \
+ --without-jemalloc \
+ --without-libbpf \
+ --without-libnghttp3 \
+ --without-libngtcp2 \
+ --without-libxml2 \
+ --without-mruby \
+ --without-neverbleed \
+ --without-systemd \
+ "$(want_check && echo --with-cunit || echo --without-cunit)"
make
}
@@ -58,18 +72,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-static() {
- pkgdesc="$pkgname static libraries"
- mkdir -p "$subpkgdir"/usr/lib
- cd "$pkgdir"
- for _lib in $(find . -name '*.a'); do
- mkdir -p "$subpkgdir"/${_lib%/*}
- mv "$_lib" "$subpkgdir"/${_lib%/*}/
- done
-}
-
sha512sums="
-756b78665ef9fe8765332e7f0b249029d845a6b635c00a27f4c3716a1354f98bcc34df4da74179213497f6bfc2647d3773ecff2b192c63427447e37cf6393f6c nghttp2-1.44.0.tar.xz
-d3f6a66ad6522babb5ad2b3721d52c1c2af88e57ed2895cf87037da1032ca42dcb95dacc23ea277b9507b4116cec117b5c9a3313759dc56b48199b687b74dd9a remove-mruby-tests.patch
-ad9a645e00d33747338cd23d1d0ff7c744ea6abd504b9175e086574d23881b188fd014464b660923ff37a64c0c46c4379c96374ac8997b03eb2350f9ec817740 disable-failing-musl-unittest.patch
+01e930d7caf464699505f92b76e2bc8192d168612dc564d2546812c42afea2fb81d552d70e8a5fed35e2bf5deadbec8eda095af94a2484bca41542988afce52a nghttp2-1.61.0.tar.xz
"