aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nginx/APKBUILD')
-rw-r--r--main/nginx/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 9848263bece..dfd32500df9 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -26,7 +26,10 @@ prepare() {
build() {
cd "$_builddir"
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--conf-path=/etc/$pkgname/$pkgname.conf \
--pid-path=/var/run/$pkgname.pid \
--lock-path=/var/run/$pkgname.lock \
@@ -35,12 +38,15 @@ build() {
--http-client-body-temp-path=/tmp/$pkgname/client-body \
--http-proxy-temp-path=/tmp/$pkgname/proxy \
--http-fastcgi-temp-path=/tmp/$pkgname/fastcgi \
- --user=http --group=http \
- --with-ipv6 --with-pcre-jit \
+ --user=http \
+ --group=http \
+ --with-ipv6 \
+ --with-pcre-jit \
--with-http_ssl_module \
--with-http_gzip_static_module \
--with-http_spdy_module \
- --with-mail --with-mail_ssl_module \
+ --with-mail \
+ --with-mail_ssl_module \
|| return 1
make || return 1
}