aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nginx/APKBUILD')
-rw-r--r--main/nginx/APKBUILD223
1 files changed, 144 insertions, 79 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index de3c45cea61..d6240bc1499 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -4,6 +4,18 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
#
# secfixes:
+# 1.24.0-r12:
+# - CVE-2023-44487
+# 1.22.1-r0:
+# - CVE-2022-41741
+# - CVE-2022-41742
+# 1.20.2-r2:
+# - CVE-2021-46461
+# - CVE-2021-46462
+# - CVE-2021-46463
+# - CVE-2022-25139
+# 1.20.1-r1:
+# - CVE-2021-3618
# 1.20.1-r0:
# - CVE-2021-23017
# 1.16.1-r6:
@@ -18,34 +30,42 @@
# - CVE-2018-16845
# 1.12.1-r0:
# - CVE-2017-7529
+# 0:
+# - CVE-2022-3638
#
pkgname=nginx
# NOTE: Upgrade only to even-numbered versions (e.g. 1.14.z, 1.16.z)!
# Odd-numbered versions are mainline (development) versions.
-pkgver=1.20.2
-pkgrel=0
+pkgver=1.24.0
+pkgrel=18
# Revision of nginx-tests to use for check().
-_tests_hgrev=823f603da727
-_njs_ver=0.7.0
+_tests_hgrev=22f45bf99a9e
+_njs_ver=0.8.3
+# if this isn't set higher than testing/openresty that comes first for some reason
+# even though this has a higher version..
+provider_priority=100
pkgdesc="HTTP and reverse proxy server (stable version)"
url="https://www.nginx.org/"
arch="all"
license="BSD-2-Clause"
-depends=""
makedepends="
brotli-dev
gd-dev
geoip-dev
+ hiredis-dev
+ jansson-dev
libmaxminddb-dev
libxml2-dev
libxslt-dev
linux-headers
- openssl1.1-compat-dev
+ openssl-dev>3
pcre-dev
perl-dev
pkgconf
zeromq-dev
zlib-dev
+ zstd-dev
+ !zstd-static
"
checkdepends="
gd
@@ -63,21 +83,29 @@ _grp_www="www-data"
pkggroups="$_grp_ngx $_grp_www"
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade $pkgname.post-upgrade"
subpackages="$pkgname-debug $pkgname-doc $pkgname-openrc $pkgname-vim::noarch"
-source="https://nginx.org/download/$pkgname-$pkgver.tar.gz
+source="https://nginx.org/download/nginx-$pkgver.tar.gz
+ CVE-2023-44487.patch
$pkgname-tests-$_tests_hgrev.tar.gz::https://hg.nginx.org/nginx-tests/archive/$_tests_hgrev.tar.gz
$pkgname-njs-$_njs_ver.tar.gz::https://hg.nginx.org/njs/archive/$_njs_ver.tar.gz
nginx-dav-ext-module~pr-56.patch::https://github.com/arut/nginx-dav-ext-module/pull/56.patch
nginx-dav-ext-module~pr-62.patch::https://github.com/arut/nginx-dav-ext-module/commit/bbf93f75ca58657fb0f8376b0898f854f13cef91.patch
- nginx-module-vts~01-938c19d.patch::https://github.com/vozlt/nginx-module-vts/commit/938c19d2e49d5f3355df5375725982d15f1270c4.patch
- nginx-module-vts~02-ad40022.patch::https://github.com/vozlt/nginx-module-vts/commit/ad4002262c19e81390f518a14f99bb594862c575.patch
- nginx-module-vts~03-c08781c.patch::https://github.com/vozlt/nginx-module-vts/commit/c08781c5095d9e6090c47176bdea322ce983ecb6.patch
- nginx-module-vts~04-1a01a87.patch::https://github.com/vozlt/nginx-module-vts/commit/1a01a87e66c9f111fb399cf40def33ab193ae393.patch
- nginx-module-vts~05-ead62a0.patch::https://github.com/vozlt/nginx-module-vts/commit/ead62a0caf405731c88ac138c4c0a82bb316cc18.patch
- nginx-module-vts~fix-uri-overflow.patch
- nginx-module-vts~cast-key-length-to-correct-type.patch
- nginx-module-vts~set-histogram-buckets-on-first-request.patch
+ no-werror.patch
traffic-accounting-nginx-module~disable-stream-module.patch
+ traffic-accounting-nginx-module~fix-memory-leak.patch
nginx_cookie_flag_module~fix-mem-allocations.patch
+ njs~mktemp-busybox-compat.patch
+ naxsi~assert.patch
+ naxsi~ff-header.patch
+ naxsi~compat.patch
+ nginx-upload-progress-module~fix.patch
+ nginx-upload-progress-module~fix-http2.patch
+ ngx-fancyindex~fix-404-on-fs-root.patch
+ ngx-fancyindex~fix-missing-saturday.patch
+ nchan~dont-fail-redis-cluster-before-consensus.patch
+ nchan~fix-redis-race-condition.patch
+ nginx-upload-module~fixes.patch
+ nginx-upload-module~fix-nginx-compat.patch
+ zstd-nginx-module~fix-infinite-loop.patch
nginx.conf
default.conf
stream.conf
@@ -85,18 +113,17 @@ source="https://nginx.org/download/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
"
-builddir="$srcdir/$pkgname-$pkgver"
_modules_dir="usr/lib/$pkgname/modules"
_stream_js_depends="$pkgname-mod-stream"
case "$CARCH" in
- riscv64) _has_luajit=false;;
+ ppc64le|riscv64) _has_luajit=false;;
*) _has_luajit=true; makedepends="$makedepends luajit-dev";;
esac
case "$CARCH" in
- x86 | s390x | mips64 | armv7 | armhf) _njs_mods= ;; # has failing tests
+ x86) _njs_mods= ;; # has failing tests
*) _njs_mods="http-js stream-js";;
esac
@@ -127,7 +154,12 @@ _add_module() {
# Don't add new flag and source if it's already there, i.e. two or more
# modules share the same source (e.g. geoip2 that provides http-geoip2
# and stream-geoip2).
- if ! printf '%s\n' $_extra_flags | grep -qFw "$srcdir/$dirname"; then
+ local present=false
+ case "$_extra_flags" in
+ *="$srcdir/$dirname"*) present=true;;
+ esac
+
+ if ! $present; then
source="$source $dirname.tar.gz::$url/archive/$ver.tar.gz"
# $source must be always in-sync with $sha512sums, so we have to
# add there source of a module that is disabled on the current arch.
@@ -138,42 +170,47 @@ _add_module() {
subpackages="$subpackages $pkgname-mod-$name:_module"
}
-_add_module "devel-kit" "v0.3.1" "https://github.com/vision5/ngx_devel_kit"
+_add_module "devel-kit" "v0.3.3" "https://github.com/vision5/ngx_devel_kit"
_devel_kit_so="ndk_http_module.so"
_add_module "http-accounting" "v2.0" "https://github.com/Lax/traffic-accounting-nginx-module"
-_add_module "http-array-var" "v0.05" "https://github.com/openresty/array-var-nginx-module"
+_add_module "http-array-var" "v0.06" "https://github.com/openresty/array-var-nginx-module"
_http_array_var_depends="$pkgname-mod-devel-kit"
+_add_module "http-auth-jwt" "0.6.0" "https://github.com/kjdev/nginx-auth-jwt"
+_http_auth_jwt_desc="Nginx third-party module kjdev/nginx-auth-jwt (version $_http_auth_jwt_ver)"
+
_add_module "http-brotli" "v1.0.0rc" "https://github.com/google/ngx_brotli"
_http_brotli_so="ngx_http_brotli_filter_module.so ngx_http_brotli_static_module.so"
-_add_module "http-cache-purge" "2.5.1" "https://github.com/nginx-modules/ngx_cache_purge"
+_add_module "http-cache-purge" "2.5.3" "https://github.com/nginx-modules/ngx_cache_purge"
_add_module "http-cookie-flag" "v1.1.0" "https://github.com/AirisX/nginx_cookie_flag_module"
_http_cookie_flag_so="ngx_http_cookie_flag_filter_module.so"
_add_module "http-dav-ext" "v3.0.0" "https://github.com/arut/nginx-dav-ext-module"
-_add_module "http-echo" "v0.62" "https://github.com/openresty/echo-nginx-module"
+_add_module "http-echo" "v0.63" "https://github.com/openresty/echo-nginx-module"
-_add_module "http-encrypted-session" "v0.08" "https://github.com/openresty/encrypted-session-nginx-module"
+_add_module "http-encrypted-session" "v0.09" "https://github.com/openresty/encrypted-session-nginx-module"
_http_encrypted_session_depends="$pkgname-mod-devel-kit"
-_add_module "http-fancyindex" "v0.5.1" "https://github.com/aperezdc/ngx-fancyindex"
+_add_module "http-fancyindex" "v0.5.2" "https://github.com/aperezdc/ngx-fancyindex"
-_add_module "http-geoip2" "3.3" "https://github.com/leev/ngx_http_geoip2_module"
-_add_module "stream-geoip2" "3.3" "https://github.com/leev/ngx_http_geoip2_module"
+_add_module "http-geoip2" "3.4" "https://github.com/leev/ngx_http_geoip2_module"
+_add_module "stream-geoip2" "3.4" "https://github.com/leev/ngx_http_geoip2_module"
_stream_geoip2_depends="$pkgname-mod-stream"
-_add_module "http-headers-more" "v0.33" "https://github.com/openresty/headers-more-nginx-module"
+_add_module "http-headers-more" "v0.37" "https://github.com/openresty/headers-more-nginx-module"
_http_headers_more_so="ngx_http_headers_more_filter_module.so"
+_add_module "http-keyval" "0.2.0" "https://github.com/kjdev/nginx-keyval"
+
_add_module "http-log-zmq" "v1.0.0" "https://github.com/danifbento/nginx-log-zmq"
# luajit is required for lua-nginx-module since v0.10.14
-_add_module "http-lua" "v0.10.20" "https://github.com/openresty/lua-nginx-module" "" "$_has_luajit"
+_add_module "http-lua" "v0.10.26" "https://github.com/openresty/lua-nginx-module" "" "$_has_luajit"
_http_lua_depends="$pkgname-mod-devel-kit lua-resty-core"
_http_lua_provides="$pkgname-lua" # for backward compatibility
@@ -183,36 +220,40 @@ _http_lua_upstream_depends="$pkgname-mod-http-lua"
_add_module "http-naxsi" "1.3" "https://github.com/nbs-system/naxsi" "naxsi_src"
_naxsi_provides="$pkgname-naxsi" # for backward compatibility
-_add_module "http-nchan" "v1.2.8" "https://github.com/slact/nchan"
+_add_module "http-nchan" "v1.3.6" "https://github.com/slact/nchan"
_http_nchan_so="ngx_nchan_module.so"
_add_module "http-redis2" "v0.15" "https://github.com/openresty/redis2-nginx-module"
-_add_module "http-set-misc" "v0.32" "https://github.com/openresty/set-misc-nginx-module"
+_add_module "http-set-misc" "v0.33" "https://github.com/openresty/set-misc-nginx-module"
_http_set_misc_depends="$pkgname-mod-devel-kit"
-_add_module "http-shibboleth" "v2.0.1" "https://github.com/nginx-shib/nginx-http-shibboleth"
+_add_module "http-shibboleth" "v2.0.2" "https://github.com/nginx-shib/nginx-http-shibboleth"
-_add_module "http-untar" "v1.0" "https://github.com/ajax16384/ngx_http_untar_module"
+_add_module "http-untar" "v1.1" "https://github.com/ajax16384/ngx_http_untar_module"
+
+_add_module "http-upload" "2.3.0" "https://github.com/fdintino/nginx-upload-module"
_add_module "http-upload-progress" "v0.9.2" "https://github.com/masterzen/nginx-upload-progress-module"
_http_upload_progress_so="ngx_http_uploadprogress_module.so"
_add_module "http-upstream-fair" "0.1.3" "https://github.com/itoffshore/nginx-upstream-fair"
-_add_module "http-upstream-jdomain" "1.1.5" "https://github.com/nicholaschiasson/ngx_upstream_jdomain"
+_add_module "http-upstream-jdomain" "1.5.0" "https://github.com/nicholaschiasson/ngx_upstream_jdomain"
-_add_module "http-vod" "1.28" "https://github.com/kaltura/nginx-vod-module"
+_add_module "http-vod" "1.33" "https://github.com/kaltura/nginx-vod-module"
-_add_module "http-vts" "v0.1.18" "https://github.com/vozlt/nginx-module-vts"
+_add_module "http-vts" "v0.2.2" "https://github.com/vozlt/nginx-module-vts"
_http_vts_so="ngx_http_vhost_traffic_status_module.so"
-_add_module "http-zip" "1.2.0" "https://github.com/evanmiller/mod_zip"
+_add_module "http-zip" "1.3.0" "https://github.com/evanmiller/mod_zip"
+
+_add_module "http-zstd" "0.1.1" "https://github.com/tokers/zstd-nginx-module"
+_http_zstd_so="ngx_http_zstd_filter_module.so ngx_http_zstd_static_module.so"
_add_module "rtmp" "v1.2.2" "https://github.com/arut/nginx-rtmp-module"
_rtmp_provides="$pkgname-rtmp" # for backward compatibility
-
prepare() {
local file; for file in $source; do
file=${file%%::*}
@@ -243,6 +284,17 @@ _build() {
export LUAJIT_LIB="$(pkgconf --variable=libdir luajit)"
export LUAJIT_INC="$(pkgconf --variable=includedir luajit)"
fi
+
+ # Fix compilation with gcc 13.1.
+ # TODO: Remove after upgrade to njs 0.7.13.
+ # https://github.com/nginx/njs/commit/e60d10f2007c332391d7a104453e13567ebbe52d
+ export NJS_CFLAGS="-Wno-error=dangling-pointer"
+
+ # Enable support for Redis store in the http-keyval module.
+ export NGX_HTTP_KEYVAL_ZONE_REDIS=1
+
+ # --without-pcre2 - Lua module is not compatible with PCRE2 yet
+ # https://github.com/openresty/lua-nginx-module/issues/1984
./configure \
--prefix=/var/lib/$pkgname \
--sbin-path=/usr/sbin/$pkgname \
@@ -262,6 +314,8 @@ _build() {
--with-threads \
--with-file-aio \
\
+ --without-pcre2 \
+ \
--with-http_ssl_module \
--with-http_v2_module \
--with-http_realip_module \
@@ -298,8 +352,6 @@ _build() {
}
build() {
- cd "$builddir"
-
_build --with-debug
mv objs objs-debug
@@ -318,18 +370,18 @@ check() {
;;
esac
- TEST_NGINX_BINARY="$builddir/objs/nginx" prove .
+ : ${JOBS:-1}
+ TEST_NGINX_BINARY="$builddir/objs/nginx" prove -j $((JOBS > 20 ? 20 : JOBS)) .
- if [ -n "$_njs_mods" ]; then
- msg "Running njs tests..."
- cd "$srcdir"/njs-*
- make test
- fi
+ # FIXME: see !46437
+ #if [ -n "$_njs_mods" ]; then
+ # msg "Running njs tests..."
+ # cd "$srcdir"/njs-*
+ # make test
+ #fi
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
chown root:root "$pkgdir"/usr/sbin/nginx
@@ -399,6 +451,7 @@ _module() {
pkgdesc="Nginx module ${name//_/-}"
[ "$ver" ] && pkgdesc="Nginx third-party module ${name//_/-} (version $ver)"
+ pkgdesc="$(getvar "_${name}_desc" "$pkgdesc")"
url=$(getvar "_${name}_url" "$url")
sonames=$(getvar "_${name}_so" "ngx_${name}_module.so")
depends="$pkgname $(getvar "_${name}_depends")"
@@ -431,7 +484,7 @@ _module() {
;;
stream)
mkdir -p ./etc/nginx/stream.d
- install -m644 "$srcdir"/stream.conf ./etc/nginx/stream.conf
+ install -m644 -D "$srcdir"/stream.conf ./etc/nginx/conf.d/stream.conf
;;
esac
}
@@ -442,53 +495,65 @@ getvar() {
}
sha512sums="
-8b65e881ea4ac6162cbf32e5e95cf47a6d5418819f8763ca4a781cffa38187dd7886d4bc195d000a7046111a27121ff25800f8645405174995247e6738b4279a nginx-1.20.2.tar.gz
-86b59768dbe2812f91cd10d9d35e29904caea4b5d0b616f93b7d763b383f5fa31e993590511244c42a817c68fae097df976e790475876ed88a33b3727c044898 nginx-tests-823f603da727.tar.gz
-e8894b010b51c282bcfa1c167727ef337d1e4db1189af0e748cb07e6c6132d443b1c32157d4985e9fd7ab776864fb6025e6ffc3018aef56f9ea0c8bfa17c7742 nginx-njs-0.7.0.tar.gz
+1114e37de5664a8109c99cfb2faa1f42ff8ac63c932bcf3780d645e5ed32c0b2ac446f80305b4465994c8f9430604968e176ae464fd80f632d1cb2c8f6007ff3 nginx-1.24.0.tar.gz
+18b69643648119dfab45101bb9404be667aeb9d550aa3bc9706e63e7da1c2806106e9a6bbfb2d10bd57ef56b9b5b0b524059353ec30a51469b44641cb7dbd8a6 CVE-2023-44487.patch
+d882d7f79814bd5caf323099aef318a5f4c75c2eb81f13bbd9688fd5404f5a2e4dc653dbc23121f77cc5ccf59742f80fb34db38b8788030c54b376eb9a2065ff nginx-tests-22f45bf99a9e.tar.gz
+1cec9a322c40aa2b4ec6eb5bea78d7442880b0cff3a41ad171a3dc3157a6990baec6c8b9eda99ee02a9e51c0b933f13ef17431079a5ff409aaf84b912c7f4df7 nginx-njs-0.8.3.tar.gz
4c7a94aaebbb69599b0067e74f9f3db54ec383ca9499292fec5b875bb0b5859aa11dc14cef5664c94dd54aba231f31e85feacddc49f7622aa4d0fdb38709b6e1 nginx-dav-ext-module~pr-56.patch
fdd66e433126e194a3ef22737993191a04fcc4c8caa044b27cb22bea0e7f16c8fdbc900553507d2bb541cdb82b542845a297db2a48c2460a38dd772d0ebfca9d nginx-dav-ext-module~pr-62.patch
-fa96e91f495e9891c03730bcafd948e597e7c5d74f2d30df0a8483ae04f7b30c89065a994a0baa5245470f8991db5844b26da925b23ff26c178a384f5f1a887c nginx-module-vts~01-938c19d.patch
-1c37e58921478325bb4dd608900588cda49d608e859127f45a1df73176b228b060bf71d9530dc1ad434a287c7a3225e8fe307fcf1bd15758f327436283db6fb9 nginx-module-vts~02-ad40022.patch
-9f9cda2f3f163654100adf9cde892b26f80d3de30ffec9fcdb0b3c1a42856f9219ebb024fd4c156fd8c4c4a6c7b17faca89e16916128da232d9f3bc825d716ff nginx-module-vts~03-c08781c.patch
-e87d9c8cbebc147881e3a40e6944acfe836f29eb7b393af0465b04dd27f1fa42f17ab63d2bcc75053812140a92dceca4eb4e1f0e35877919af4bd3cd0b2b771a nginx-module-vts~04-1a01a87.patch
-dfcfd4dd14ccb205ea80d28eae8cadd123015d5eddc004a31b7742d8117c69cad1b56868ba94dd75e22b7ef9f44da21c02e5f5f1ecd4f90473cd9fa6128518c5 nginx-module-vts~05-ead62a0.patch
-5d6b5b2f409d8183576d7d58f75a92b859922e6dc6d2e12d3abb92f3491eca4962231c1ba5860366fd83c86283711b79a19c3c7823f042267f14925d7a49cc78 nginx-module-vts~fix-uri-overflow.patch
-90efd127fef5c89ae3148ab626a4061875d84af376d41b2bd36b2cf3188c2a244013bf1d3b09fbde51b68f59f0893e0bfaf929319aeb818904c8cdadd853c229 nginx-module-vts~cast-key-length-to-correct-type.patch
-48689e09dc87f395095408127669c9f21a32c13b1b700ffad225db0c8920ae9e4f08e88332c12c01d96ded2d091ad2033885d81d5d7c9479745b10620f36562d nginx-module-vts~set-histogram-buckets-on-first-request.patch
+c89fab6d3d4226e37f2a8d2122d825046fc9a787e464fc75351a19fbda5b47016ddb907e0a61241a007304af921e11a0715895ba7b6d4c1112afe816177ed02a no-werror.patch
09ec9f18323197eafa55ff68e8c836ad3dd830e6cd3bd4aeaf34e179ef3f72f734a0117288c1c58813aff59f3f1f0f29ccd772a672e17551e7a4fd0693a89c92 traffic-accounting-nginx-module~disable-stream-module.patch
+5a7e72fc6ade460b725e6b91d5eafeb2792ad9832fbdb84ed868bd9a25d43116e42877df587b5f3885a1e38769f072ed4e8605393aca672d61bc71dd106d392b traffic-accounting-nginx-module~fix-memory-leak.patch
ac0f912ae90e0083cc761a622290223edeed0bd32213bbe766d637ac2dfd9835d163e5d16ef28740cbad05d6d92cc418d62df3413c70b4f2c63db02f8ca1c7cc nginx_cookie_flag_module~fix-mem-allocations.patch
-9c5ee975dffa15b76688ef798371635f38f1e6773b143c738add26297878dddfc20ebf276e3871a60f28b197e8a70496ca17d4816c2136171978c157bb8e591f nginx.conf
+4db527d663dbe9e8b503c3cbaa4eae34b45990a5359b3bb98ce970c705faefcac98de49439f2557756a2be8e2e06acc67f98942de01674c498832d80c3cb90c3 njs~mktemp-busybox-compat.patch
+eee45b82a594c4dfa5eecf94cf14cd247bd1dd7d627aa0a26666828b3e2da1a358da251a23f0b5feeb5f95f6ba205af6ead54c1e6bcb67f6d11149c0580de3af naxsi~assert.patch
+7c35f51d73b6c20b6b9b030e76a4898752eae38e0f8e4001286a93633f0b1b11c39fd883116d86a323338027766d15d99c824a9cd9ffe934bea80b7af2a3070c naxsi~ff-header.patch
+3e000d58e1259a656bb49af23623e6542ec994e3fe699e0005afde9ded5d505e7a174b206390b55ef639e53fd47516a86d88de675df86d550808da1d2732e683 naxsi~compat.patch
+745e900573bc4d1ca6dd40da4743387f9ffaa764cca59591fcbfb1afe67980e529184f81a7cf8f047ddd1962a6a26ed65f1589d69a4f63f6f5701549f38a0652 nginx-upload-progress-module~fix.patch
+24bcde151301ed41eaea65c3792219b25dbb76e3eddd74064937038326698b83d6620d2515a954984502ad2a1c6c53843680952c2ce813f2da34652047675ddf nginx-upload-progress-module~fix-http2.patch
+37ad4288684d8918045d406f9f46510211413ab343e47aa149e52fd773ad95e6ff10a1b4e7cdd60acaf9231a0c6a935ab489c25880444f1a79e8624693fa166e ngx-fancyindex~fix-404-on-fs-root.patch
+d54eb2152b2ddbf3e8956cb7b4634b1657635b21b9b4f91309d45a43553c9506ad70161d265e0840c1e84c9e04c0e89061600176ad2ec39311b5c0ce75e42f1e ngx-fancyindex~fix-missing-saturday.patch
+abda15727e34178db2f8013a1c47e480ba323a3b3b88a44bbada0169b8ce66743911ec7b551272fc8540199070b62eadc78a19989f770794b43877c6743f573d nchan~dont-fail-redis-cluster-before-consensus.patch
+2a87aee322a146a55e58d48636cdb6a3a182c308a6fe5327c9c2ece0487f669fe6b3f231f56e395e12b7c2ae2dd929a72a03dc18b1032ccc733184aac50d2381 nchan~fix-redis-race-condition.patch
+ef57603bd65ffbbb216fd748dab0126d3df7aafdfa70dce0ea9ef91373df95269546ec2fcaa03f842a8db3a16879274184a23b18db17b4f9be3916aedacb7765 nginx-upload-module~fixes.patch
+bae6c3153810bf6f460248668f2c48e332aba37081e25e45a1691344508530ef1be9acee4d52f506cb09510c4fce8d93ca3178ba45af771c54e37126f4f11b1b nginx-upload-module~fix-nginx-compat.patch
+97ed3a3ad636a8853a993db3a33c67da303063e7ac43c20eeac6afb9f71adafa5dedf5f5f8c6705a256294c0566e3ac9f5fa41930048ad80b10a7d2a7d3c9b53 zstd-nginx-module~fix-infinite-loop.patch
+c209a220b6afc9354a1c4c39817199327425485b3da44778d632cdfd1d95b8412c58ba9b27a5c96599e7a34cc039f5b7d914ad82153c610b27dfbe21fdcdca77 nginx.conf
0907f69dc2d3dc1bad3a04fb6673f741f1a8be964e22b306ef9ae2f8e736e1f5733a8884bfe54f3553fff5132a0e5336716250f54272c3fec2177d6ba16986f3 default.conf
-f3321a45736697009817db335ad36d3f1d05f60d98ac90a943220cdd4c00c52632f018db6a6076d5431a483525aacc5725b87b765b590e2f63b3ef98c5b16bd8 stream.conf
+426f0c317322af7cab152f2070398c7aa5c059276ba504617a212f1e060bbb1dd9edc54e62d4cf5f14e3678235351c808ebeabe8b122757c74b3f505e8427106 stream.conf
09b110693e3f4377349ccea3c43cb8199c8579ee351eae34283299be99fdf764b0c1bddd552e13e4d671b194501618b29c822e1ad53b34101a73a63954363dbb nginx.logrotate
ee10a5687740dde0c3d18d8b3555f49fcdc6abfc0a3bc2de1de3be0e99951a346fe8027d916aab73071ecd4e2c50871e7c867aca3a7a0fd16e3374c5caed1c57 nginx.initd
0b9b9ed01ac077e334c034faa2679f6e26740fb3362eebf8cef82d22b2af2a3faaa53bae3c9e14af51cbf64720a7c66431905ca5cc43f978366456cc4e3b7f4a nginx.confd
-de1e3349d8dd08e5982279b2219dc8a8006739f0409b8e0f5c50d93434beff1fbafba43e9c5ac85a5fab90afc5c0a7244a340610339c36f82f2cba7233e72de9 ngx_devel_kit-0.3.1.tar.gz
+a255e3a4a9b902b3e15140dc88bbbb152b0a9cdc64604152de41e1b254e81aa2a1e2c95c06cb4905c1520886acf9070031d63913b53fe98b034f8adad2bccf61 ngx_devel_kit-0.3.3.tar.gz
0df34c3765e18dc5cc5a053d3a17dbee17a686a1f6e76ad057c262741c4e4465c66bcef86e627a19258f836cad5f14745bf046fd396b00960ad79ed20c2a07bb traffic-accounting-nginx-module-2.0.tar.gz
-7c9fa9b76bc7cd2473ceae6d5ffb8de26993be9293ea967908d6c4550e086affa7016df4c936fb0b79f1142dc0aa1a5f2058d417e6433b5a3497a45d7e866e84 array-var-nginx-module-0.05.tar.gz
+bc72158856a1be18a26ee04c6b5b0f0a20bcce688610a493bf31e2a133e7eb12e11f7c18197a09a72b1513f6a08348ee5281b9d5b84cf43603539040ebd23c26 array-var-nginx-module-0.06.tar.gz
+56fe87b7b456856c167b47e5dfc579ac77f15487785dd8411397f6041561b991218518218b4adf3054392fdf1569469a4eff288706f320cf8d2c45b066ef780b nginx-auth-jwt-0.6.0.tar.gz
05a880d5e48ac83be84498ed41fb4750211b827a9d7541acfd6ef494e5205a6e853d5594bfec3ab4ae668ea3f803e4f4b0ba550c76811971c8e266e42663c56d ngx_brotli-1.0.0rc.tar.gz
-3ad37b4a251fb85a9a384f87fea5ca640166e3d7173c6ed9a857b191ae5f2e93819483b5d423fcafe8a10239b571677b342cc2d2d5d62315816f1316d7d5bb76 ngx_cache_purge-2.5.1.tar.gz
+aebc9b19a3e7dda3b57e6bd6d86a5ab66d25e05cf5c6c99c71234c789700eb9da8e29529b8b2abf3d775ff3c2610e695fc88e647738769f0d3730bcafc3be38b ngx_cache_purge-2.5.3.tar.gz
352cc3d033cc67ee34209f958dac13ada2147de429f4dd3da301c865d52970d80c8aa3c193f7fb28cf4854b88baff07b6efc3bae1fb813fe53d5956a87dfc81a nginx_cookie_flag_module-1.1.0.tar.gz
d0193ba90f1ef46c4e470630c4394bdf99d94fd2e3bd8be6cb2ba1655ec59944b1269025f032b79dc2c6dad366e54389ef6a6da2ddeb91d535a4027f2162fbde nginx-dav-ext-module-3.0.0.tar.gz
-240896b1c559a71ca6ca87136d8535edd25b1d65ebb80d46080ad41c09ed1cec9737828f9efe260782294d660cea66cf402f4e75bba3fed26f3a94de0ae2f89b echo-nginx-module-0.62.tar.gz
-80651951edd69d202e991a66f531bbe0398b4f062e822bb7748411f5f597eb1d5827102ba477bb6cd2793274adf6f6d60dd89fde7645174b091143251197af69 encrypted-session-nginx-module-0.08.tar.gz
-5c9252713286056cb493b734c8aabef51538c4c3c3204404eecc6c09dffcd06f733ed4f134af8f5d38558db75ac0a6161a1fa29ae98284b68b30309d9a5e6b31 ngx-fancyindex-0.5.1.tar.gz
-06963b598c54e22d75ce837fb222f5aa6c9494c29e558ff46f1205d7159fc305414bfac4ed3288c836dcbf7628d92f26458e1992d34fc2f4b73275a32847bdc0 ngx_http_geoip2_module-3.3.tar.gz
-13165b1b8d4be281b8bd2404fa48d456013d560bace094c81da08a35dc6a4f025a809a3ae3a42be6bbf67abbcbe41e0730aba06f905220f3baeb01e1192a7d37 headers-more-nginx-module-0.33.tar.gz
+c325ac4e3f3f735739e156d8c7ada503b34475c62533b4830231ff1b42c25cb0c841aae06b3448b589c2ab35da8d211436ed194d6fd062cad925af8152c5e789 echo-nginx-module-0.63.tar.gz
+399ce2690e85ee27802e8031954a1a3aa3fdc9246e17323a72a298d235931a8dbebdcb121ac8788e074872df0ef5b5a8a3d512b17fbe860b38f696ce42de3655 encrypted-session-nginx-module-0.09.tar.gz
+c208cdf3e245527d7b313f9ef1f5d36ca26e3bdafe67df56492a13b7726587538665e5d9fd50f295fc933f218dc33394f2fe442713d15631701dbfc4a156799b ngx-fancyindex-0.5.2.tar.gz
+18dea21e5ae2647bea1fc448058a1b773c936917245edef8d861d5e23ed92e9a3b1ec4ef43ffb2ece7b5899d787910adcf4fbd39f84d7e8d7c54759e2fee5b72 ngx_http_geoip2_module-3.4.tar.gz
+0cc2fffe506194d439e3669644d41b7943e2c3cffa3483eb70b92067930b358d506a14646eff8362b191a11c624db29f6b53d830876929dcb4ce1c9d7b2bc40d headers-more-nginx-module-0.37.tar.gz
+45b8f107a492f415f5053b9b95d3dad481d5736c603b87c1342541214e89b9acbe37925f93acc396782406232e607879b52f9bb480f9021c10d405b832298022 nginx-keyval-0.2.0.tar.gz
015a358d987476bb61302fbbe1cb105f5314edc1a8b7ee6310aae697f755c79fcb1834ff561fced054c8cd5624f5387fcc1de729731ccd70662f2eb72bcdc174 nginx-log-zmq-1.0.0.tar.gz
-f11154d82ed9e15fc156971318f8e81fd873ec887370921c58da777061caf00dfb51b2eca3afba3b82d2330f285508f9885649a993c6091e1283f9d2179d10af lua-nginx-module-0.10.20.tar.gz
+9abf00844ef00ce1dc5ff08d6fe4ddccf843f2ad2de6fd450854b38a66b45add71e814205dba9b19225b9165e67eb93578e83e5fe37af4e0c891e61e6a6bfb3d lua-nginx-module-0.10.26.tar.gz
72887c4490854b099cb26bb3f840073a36b0d812bde4486f04dc1be182ca74f0d1e3fd709e77c240c2dcf37665f74cf04e188ea9efe8e127c6789b27b487d0cd lua-upstream-nginx-module-0.07.tar.gz
d7aac69b5eceeb1b0db4741201159ade1e0e7f6f7c3e8c4afa2f8959c6c00c3b5285d5185747c2fb0b1400efda02e96799836315e7e492bb4a059b14acb2142d naxsi-1.3.tar.gz
-bea5ce8669f43f752a42f5988125ac1beb7c7904e780605f7706bbb03e9ab4f30a2bcbcddac5bc1c67cff4d92f798023ec320e8d9a2db47953f9f7b08b5ad882 nchan-1.2.8.tar.gz
+0f1c25d460dcf4e3407a1ef4bfcefe17eba7b0ff250f267e5bde0eb4298e9596c1e6992fc58fe35d8420888065353bf3883a1f1bbc5e607a00128992eb1ee6d2 nchan-1.3.6.tar.gz
d6ca250db8de93edbd7875afca35e73cecdaf82132d1a7ee933cf94c6b8afa8e629e9e647a9321f2bc1fbb92137ec0d32dcd89b82ac5fae31e342537fb7e0431 redis2-nginx-module-0.15.tar.gz
-5590526f60c99630f99a49bfa9e3455baee6d58cd2a1419eab1367a838dafb87a50f5e2607aa8ac557b90dbf633dcf61069c997b3526cddc8f2fc45820a7bc3b set-misc-nginx-module-0.32.tar.gz
-1730845ea2e52be8c2f6cfceb2894304c5a07959a96940bb1617ee0e7cf81d22283304f411d9a219ddb71e4d9a66012bba0f6f5574d101aeb3c406f26c5d6a4e nginx-http-shibboleth-2.0.1.tar.gz
-5b0800ffb98ae69d3505d9046bc7f660defa14d21b74a4e425a4b07db917e39fd9a324851be8c424f5b4b4ef83997e09d9053eb8aa9e9f1889513dd742b5abba ngx_http_untar_module-1.0.tar.gz
+1ff4c947538a5bd5f9d6adcd87b37f2702f5cc90e3342bc08359cbe8f290b705a3a2daa3dedfb1df3ce4bc19478c8fcac07081c4a53a804fc2862d50078278dc set-misc-nginx-module-0.33.tar.gz
+0f0c5167e999ffad0caa816d4b7d0a121f0598d578391834fe3293a3e023453d91b36ffc32a431ff3af3f9f376d2d78703998560094d20643b4049c2fec84bda nginx-http-shibboleth-2.0.2.tar.gz
+c3a7dd29c4a4e47d396b19622a290a04d4cceb97c1b8a508bc984eb8c81d17da4bf5789514bb996987f8343bc801ee4457a86a274bde98b49a809afdfc04cbde ngx_http_untar_module-1.1.tar.gz
+a0da355888398f86a6b5d065e58c05f9e057589ee785be9f515d77d7a020ae5a7b0656f5af30fb3b026f457326db2e26f4fed29026221ec5fc8156ef8586da25 nginx-upload-module-2.3.0.tar.gz
c31c46344d49704389722325a041b9cd170fa290acefe92cfc572c07f711cd3039de78f28df48ca7dcb79b2e4bbe442580aaaf4d92883fd3a14bf41d66dd9d8c nginx-upload-progress-module-0.9.2.tar.gz
8adb7453c27748f4e685e3352e9b318b408da818754dc5b6244e908423941a8ba337561104f6e481f2553cbc0e334dcea73b57f8e810a9d6e974bb69ff8859e5 nginx-upstream-fair-0.1.3.tar.gz
-54a0aae25a80f285e76344e6d0759e9a1b707be4bc0755abf4b7e48918c8e37092b7b259d052215d875be447d79717c0626797ea449677c492aa1e473cc448fd ngx_upstream_jdomain-1.1.5.tar.gz
-389137124a3d046b99faabb977b5dbcf7c84541e039da27dfcca6b863d6d7f99e4b42916be1d7202bad017a88973c2f931985c2c58243f5134b7d9d199cdff0c nginx-vod-module-1.28.tar.gz
-86b980095b3b80c8dce2e355db514cb4b3039c8408a2f5ca6df9e105d5462952fddd70f6581ec6aa2763e560b591664c27eefd978c4ea777b1f1f808bc60d4ec nginx-module-vts-0.1.18.tar.gz
-92e1e5aa570b68a19bb718817f864c4347f6dc89f90d828071ab3d06c784cc2786674d9d64fffef8c23749d0a653f2eb996b412ab10015eea1ed895d81268ce1 mod_zip-1.2.0.tar.gz
+2ac8351d8d325353534c87e0ef6034a5d3897411895b4e03f22fa06343337d86897331797541ab9201cd7dc8b0376d6d76eb4458849900348f5e199e0b0bd357 ngx_upstream_jdomain-1.5.0.tar.gz
+29ef77f1bbdb2410ff317ebdd7434f31b8ec370ae6b617b92e745e87c11bc820b451181d1d2b57156b414348da14ac448b689b32b17ab418144292eda094512d nginx-vod-module-1.33.tar.gz
+7295c1af3267b067793fb88e3d3a74fdba5187742141d447f597b8d726c455bfb163209eca5d00b00a57adc3f627078b404a43f5318f910a68c6aeaffb189b1c nginx-module-vts-0.2.2.tar.gz
+8c5dda14da06ef776fe2b496c2f1b80d2c25c9269309aa560a006c369044c52917024a90f897b7212b2409a874bf2e0a3ab2dbc1e10ad84fa64f54f1f4df3d0d mod_zip-1.3.0.tar.gz
+6feb544face95121ea076db5df8ca34854085b57602e732c7ba427be5e3f2bf668729d45497a2c91212f98ed8a2c347aa8778a54594f5d241e39e094a2556e4c zstd-nginx-module-0.1.1.tar.gz
3f8c803221854c4b1a06aadc6313fbfec74bd7179c0ee51d4365b26ffa8875881a6e1e48f777a9c9efbb9170ab7478a82920d5448a2c2df485503d37bb03ab81 nginx-rtmp-module-1.2.2.tar.gz
"