aboutsummaryrefslogtreecommitdiffstats
path: root/main/npm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/npm/APKBUILD')
-rw-r--r--main/npm/APKBUILD124
1 files changed, 0 insertions, 124 deletions
diff --git a/main/npm/APKBUILD b/main/npm/APKBUILD
deleted file mode 100644
index ddc83111594..00000000000
--- a/main/npm/APKBUILD
+++ /dev/null
@@ -1,124 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=npm
-pkgver=8.3.0
-pkgrel=0
-pkgdesc="The package manager for JavaScript"
-url="https://npm.community"
-arch="noarch !mips64 !mips64el !riscv64" # limited by nodejs
-license="Artistic-2.0"
-depends="cmd:node"
-makedepends="bash nodejs"
-replaces="nodejs-doc" # for backward compatibility
-subpackages="$pkgname-doc $pkgname-bash-completion"
-source="https://github.com/npm/cli/archive/v$pkgver/npm-cli-$pkgver.tar.gz
- reproducible-documentation-build.patch
- dont-check-for-last-version.patch
- make-dont-install-deps.patch
- smoke-tests-npm-location.patch
- npmrc
- "
-builddir="$srcdir/cli-$pkgver"
-
-[ "$CARCH" = "s390x" ] && options="$options !check" # tests fail
-
-prepare() {
- default_prepare
-
- # Remove bunch of unnecessary files to reduce size of the package.
-
- rm bin/npm bin/npx bin/*.cmd bin/node-gyp-bin/*.cmd
-
- cd node_modules
-
- # Move libnpmdiff into node_modules instead of symlink
- rm libnpmdiff && mv ../workspaces/libnpmdiff .
-
- find . -type f \( \
- -name '.*' -o \
- -name '*.cmd' -o \
- -name '*.coffee' -o \
- -name '*.bat' -o \
- -name '*.map' -o \
- -name '*.md' -o \
- -name '*.ts' -o \
- -name 'AUTHORS*' -o \
- -name 'LICENSE*' -o \
- -name 'Makefile' -o \
- -name 'README*' -o \) -delete
- rm -Rf ./*/.git* ./*/doc ./*/docs ./*/examples ./*/scripts ./*/test
-
- # No files should be executable here, except node-gyp.
- find . -type f -executable ! -name 'node-gyp*' -exec chmod -x {} \;
-
- cd ../docs/content
-
- # XXX: Workaround for https://github.com/npm/cli/issues/780.
- local f name
- for f in configuring-npm/folders.md configuring-npm/install.md using-npm/*.md; do
- name=$(basename $f .md)
- sed -Ei "s/^title: $name/title: npm-$name/" "$f"
- mv "$f" "$(dirname $f)/npm-$name.md"
- done
-
- cd "$builddir"
-
- # Backup files that will be included in the package before installing
- # additional dev dependencies and running tests.
- mkdir -p "$srcdir"/npm
- cp -r bin lib node_modules package.json "$srcdir"/npm/
-
- # Install dependencies needed for mandocs and smoke-tests.
- node bin/npm-cli.js install --ignore-scripts --no-audit --no-fund
-}
-
-build() {
- # Convert Markdown docs to man pages.
- make mandocs
-
- # Generate bash completions.
- node bin/npm-cli.js completion > npm.bash
-}
-
-check() {
- make smoke-tests NPM_LOCATION="$srcdir/npm"
-}
-
-package() {
- local destdir="$pkgdir/usr/lib/node_modules/npm"
-
- mkdir -p "$destdir"
- cp -r "$srcdir"/npm/* "$destdir"/
-
- install -m 644 "$srcdir"/npmrc -t "$destdir"/
-
- mkdir -p "$pkgdir"/usr/bin
- ln -s ../lib/node_modules/npm/bin/npm-cli.js "$pkgdir"/usr/bin/npm
- ln -s ../lib/node_modules/npm/bin/npx-cli.js "$pkgdir"/usr/bin/npx
- ln -s ../lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js "$pkgdir"/usr/bin/node-gyp
-
- cd "$builddir"
-
- mkdir -p "$pkgdir"/usr/share
- cp -r man "$pkgdir"/usr/share/
- ln -s ../../../share/man "$destdir"/man
-
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
-
- install -Dm 644 npm.bash "$pkgdir"/usr/share/bash-completion/completions/npm
-}
-
-doc() {
- default_doc
-
- amove usr/lib/node_modules/npm/man
-}
-
-sha512sums="
-cca6034a4340e1d7748799a6c53646ad9143143d01868f1a0bdd19a68b09b24071eb5d2f3db8821f6648a8b21f7381feff2b57a3b598358e7d7c01fbd8615ea4 npm-cli-8.3.0.tar.gz
-2966cd932031e547dbd2a294d7f42365b08956e81e280a2b2f856c6a2db72863b9940cfd7d8fba230e5a5c1a0755f478d46845a68dd6bd8b62640bedaf194c0a reproducible-documentation-build.patch
-7b0c309fc5c4aeba48f95968ec3b5234a3a96b3b47be65337a2e8f28109a6b7ed4fbb6eb9d9bbad0ed329a21eb9c1a45744c56dfa775f5ac4b852a1d07e7a86a dont-check-for-last-version.patch
-8f18f088ee27147d763c6ebbf9d77debf8f7bb5bc79ff490cd2e5deb2cc565ae9afefc07e42d09e2d18554ea8341bf0c79942a33f7d2300cd2049fb6581c151e make-dont-install-deps.patch
-50a88e4c58ee8b47f37b78251824dc4e64668dbcefc397eb6a507736434f1a38cf72fc01adab97f8f6679ae383e91f6cfd9221c83c5ec2e5ee1c8feee1792f82 smoke-tests-npm-location.patch
-6d0ce425061ffff1c5d7a42c9908f3382cd77abf81a9c30a62ff6fff1f0d02ff633b2bb090814aa619f7d2a51237b3da7f85d97d0f584e037639b60ccfaf0e96 npmrc
-"