aboutsummaryrefslogtreecommitdiffstats
path: root/main/nspr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nspr/APKBUILD')
-rw-r--r--main/nspr/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/main/nspr/APKBUILD b/main/nspr/APKBUILD
index bb254436cd7..df5b3f11d6e 100644
--- a/main/nspr/APKBUILD
+++ b/main/nspr/APKBUILD
@@ -1,31 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nspr
-pkgver=4.24
-pkgrel=0
+pkgver=4.35
+pkgrel=4
pkgdesc="Netscape Portable Runtime"
url="https://www.mozilla.org/projects/nspr/"
arch="all"
-license="GPL-3.0-only AND LGPL-2.1-only AND LGPL-3.0-only AND MPL-2.0"
+license="MPL-2.0"
options="!check" # No test suite.
# -dev package does not ship any symlinks so dependency cannot be autodetected
-depends_dev="nspr linux-headers"
+depends_dev="$pkgname=$pkgver-r$pkgrel linux-headers"
makedepends="autoconf automake linux-headers"
subpackages="$pkgname-dev"
source="https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v$pkgver/src/nspr-$pkgver.tar.gz
- fix-getproto.patch
- fix-sgidefs-usage.patch
+ lfs64.patch
"
prepare() {
mkdir build inst
default_prepare
+ update_config_sub
}
build() {
local conf=
- if [ "$CARCH" = "x86_64" ];then
- conf="--enable-64bit"
- fi
+ case "$CARCH" in
+ arm*|x86) conf="";;
+ *) conf="--enable-64bit";;
+ esac
cd "$builddir"/build
# ./nspr/pr/include/md/_linux.h tests only __GLIBC__ version
# to detect c-library features, list musl features here for now.
@@ -42,13 +43,11 @@ build() {
}
package() {
- local file=
-
cd "$builddir"/build
make DESTDIR="$pkgdir" install
cd "$pkgdir"/usr/lib
- rm -f *.a
+ rm -f -- *.a
cd "$builddir"/build/config
install -Dm755 nspr-config "$pkgdir"/usr/bin/nspr-config
@@ -59,6 +58,7 @@ package() {
"$pkgdir"/usr/include/nspr/md
}
-sha512sums="b020031ed7a8997099c11e0772779c7b10d15b4f6b14e2b1832732943e8b8224afa952ce04a1914c1553af9d3973a6d9cacf08058ee6fff35102e3b2ec0943c1 nspr-4.24.tar.gz
-7062cc03e38541282226781e67c886c78ca693f7ee96df96509c9429470d294ca6b87ebe05ea809920b9ef78eaa0a0d21ae575a1ac438f148d0c1dc915424613 fix-getproto.patch
-69e804907d1a8867912511818d9827e4d7fd36ff44253cb21f4a5527610076874ddf5aada87717ef6454162c21248c9f7c3395376c585129134950c12f90ac0f fix-sgidefs-usage.patch"
+sha512sums="
+502815833116e25f79ddf71d1526484908aa92fbc55f8a892729cb404a4daafcc0470a89854cd080d2d20299fdb7d9662507c5362c7ae661cbacf308ac56ef7f nspr-4.35.tar.gz
+626208e91c296bb26cee84e2b5dcc2ff2d576e06dacf7008655590c0b76ea21cb33cd96994fad3b0e771e8d7d60a3d90f71f81f33a8e9c1b7ce8536f5c6cab8a lfs64.patch
+"