aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/openssl/APKBUILD')
-rw-r--r--main/openssl/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index f9cd11cc02c..c55edfccd5e 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -67,13 +67,14 @@ build() {
x86) _target="linux-elf" ;;
x86_64) _target="linux-x86_64" ;;
arm*) _target="linux-armv4" ;;
+ *) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
esac
# Configure assumes --options are for it, so can't use
# gcc's --sysroot fake this by overriding CC
[ -n "$CBUILDROOT" ] && CC="$CC --sysroot=${CBUILDROOT}"
- ./Configure $_target --prefix=/usr \
+ perl ./Configure $_target --prefix=/usr \
--libdir=lib \
--openssldir=/etc/ssl \
shared zlib enable-montasm enable-md2 \