summaryrefslogtreecommitdiffstats
path: root/main/openvpn
diff options
context:
space:
mode:
Diffstat (limited to 'main/openvpn')
-rw-r--r--main/openvpn/APKBUILD6
-rw-r--r--main/openvpn/CVE-2013-2061.patch81
2 files changed, 85 insertions, 2 deletions
diff --git a/main/openvpn/APKBUILD b/main/openvpn/APKBUILD
index 4f74f78ead9..37b26386ab9 100644
--- a/main/openvpn/APKBUILD
+++ b/main/openvpn/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openvpn
pkgver=2.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="A robust, and highly configurable VPN (Virtual Private Network)"
url="http://openvpn.sourceforge.net/"
arch="all"
@@ -12,6 +12,7 @@ makedepends="openssl-dev lzo-dev"
install=
source="http://swupdate.openvpn.net/community/releases/$pkgname-$pkgver.tar.gz
openvpn.initd
+ CVE-2013-2061.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -55,4 +56,5 @@ package() {
install -Dm755 ../openvpn.initd "$pkgdir"/etc/init.d/openvpn
}
md5sums="96a11868082685802489254f03ff3bde openvpn-2.1.4.tar.gz
-020376f1e7ed6b4adbe20cf5ff774856 openvpn.initd"
+020376f1e7ed6b4adbe20cf5ff774856 openvpn.initd
+8416c8db9c60ecb5a54367af57ac7884 CVE-2013-2061.patch"
diff --git a/main/openvpn/CVE-2013-2061.patch b/main/openvpn/CVE-2013-2061.patch
new file mode 100644
index 00000000000..732ddc22819
--- /dev/null
+++ b/main/openvpn/CVE-2013-2061.patch
@@ -0,0 +1,81 @@
+From 11d21349a4e7e38a025849479b36ace7c2eec2ee Mon Sep 17 00:00:00 2001
+From: Steffan Karger <steffan.karger@fox-it.com>
+Date: Tue, 19 Mar 2013 13:01:50 +0100
+Subject: [PATCH] Use constant time memcmp when comparing HMACs in
+ openvpn_decrypt.
+
+Signed-off-by: Steffan Karger <steffan.karger@fox-it.com>
+Acked-by: Gert Doering <gert@greenie.muc.de>
+Signed-off-by: Gert Doering <gert@greenie.muc.de>
+---
+ src/openvpn/buffer.h | 8 ++++++++
+ src/openvpn/crypto.c | 20 +++++++++++++++++++-
+ 2 files changed, 27 insertions(+), 1 deletion(-)
+
+diff --git a/src/openvpn/buffer.h b/src/openvpn/buffer.h
+index 7cae733..93efb09 100644
+--- a/buffer.h
++++ b/buffer.h
+@@ -668,6 +668,10 @@ bool openvpn_snprintf(char *str, size_t size, const char *format, ...)
+ }
+ }
+
++/**
++ * Compare src buffer contents with match.
++ * *NOT* constant time. Do not use when comparing HMACs.
++ */
+ static inline bool
+ buf_string_match (const struct buffer *src, const void *match, int size)
+ {
+@@ -676,6 +680,10 @@ bool openvpn_snprintf(char *str, size_t size, const char *format, ...)
+ return memcmp (BPTR (src), match, size) == 0;
+ }
+
++/**
++ * Compare first size bytes of src buffer contents with match.
++ * *NOT* constant time. Do not use when comparing HMACs.
++ */
+ static inline bool
+ buf_string_match_head (const struct buffer *src, const void *match, int size)
+ {
+diff --git a/src/openvpn/crypto.c b/src/openvpn/crypto.c
+index 405c0aa..d9adf5b 100644
+--- a/crypto.c
++++ b/crypto.c
+@@ -65,6 +65,24 @@
+ #define CRYPT_ERROR(format) \
+ do { msg (D_CRYPT_ERRORS, "%s: " format, error_prefix); goto error_exit; } while (false)
+
++/**
++ * As memcmp(), but constant-time.
++ * Returns 0 when data is equal, non-zero otherwise.
++ */
++static int
++memcmp_constant_time (const void *a, const void *b, size_t size) {
++ const uint8_t * a1 = a;
++ const uint8_t * b1 = b;
++ int ret = 0;
++ size_t i;
++
++ for (i = 0; i < size; i++) {
++ ret |= *a1++ ^ *b1++;
++ }
++
++ return ret;
++}
++
+ void
+ openvpn_encrypt (struct buffer *buf, struct buffer work,
+ const struct crypto_options *opt,
+@@ -244,7 +262,7 @@
+ hmac_ctx_final (ctx->hmac, local_hmac);
+
+ /* Compare locally computed HMAC with packet HMAC */
+- if (memcmp (local_hmac, BPTR (buf), hmac_len))
++ if (memcmp_constant_time (local_hmac, BPTR (buf), hmac_len))
+ CRYPT_ERROR ("packet HMAC authentication failed");
+
+ ASSERT (buf_advance (buf, hmac_len));
+--
+1.8.1.6
+