aboutsummaryrefslogtreecommitdiffstats
path: root/main/orc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/orc/APKBUILD')
-rw-r--r--main/orc/APKBUILD39
1 files changed, 14 insertions, 25 deletions
diff --git a/main/orc/APKBUILD b/main/orc/APKBUILD
index 011f6ab5aed..5edb6a414a5 100644
--- a/main/orc/APKBUILD
+++ b/main/orc/APKBUILD
@@ -2,50 +2,39 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=orc
-pkgver=0.4.31
+pkgver=0.4.37
pkgrel=0
-pkgdesc="The Oil Run-time Compiler"
+pkgdesc="Oil Run-time Compiler"
url="https://gstreamer.freedesktop.org/modules/orc.html"
arch="all"
license="BSD-2-Clause"
+depends_dev="$pkgname-compiler=$pkgver-r$pkgrel"
makedepends="linux-headers meson"
subpackages="$pkgname-dev $pkgname-compiler"
-source="https://gstreamer.freedesktop.org/src/orc/orc-$pkgver.tar.xz
- "
-
-case "$CARCH" in
- # FIXME: Test exec_opcodes_sys fails on armhf.
- # FIXME: MIPS DSP Module Rev2 is required for tests on mips*.
- arm*|mips*) options="!check";;
-esac
+source="https://gstreamer.freedesktop.org/src/orc/orc-$pkgver.tar.xz"
build() {
- cd "$builddir"
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=release \
+ abuild-meson \
+ -Db_lto=true \
-Dorc-test=disabled \
. output
- ninja -C output
+ meson compile -C output
}
check() {
- cd "$builddir"
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- cd "$builddir"
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
compiler() {
pkgdesc="Orc compiler"
- mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+
+ amove usr/bin
}
-sha512sums="4e97597e70982dbfc239d1ef9a8913b0155e5aaac15d91162d7f73a1095bd944e27fbe6d6194b9f74af07b985a44b1d9dddbe917425e1ad9e8da17ce86495696 orc-0.4.31.tar.xz"
+sha512sums="
+73c1e6e3bf66ceda94eb009675b0728ec844acc238959a4e741cbd6b69b7231b544fb85bb093641319d761bcfc0a9f84da864ab7bcf5dd1c263aa75f7b9d2310 orc-0.4.37.tar.xz
+"