aboutsummaryrefslogtreecommitdiffstats
path: root/main/pango/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pango/APKBUILD')
-rw-r--r--main/pango/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/main/pango/APKBUILD b/main/pango/APKBUILD
index 47069a762a3..f63742873b3 100644
--- a/main/pango/APKBUILD
+++ b/main/pango/APKBUILD
@@ -1,18 +1,29 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
pkgname=pango
-pkgver=1.50.7
+pkgver=1.52.2
pkgrel=0
pkgdesc="library for layout and rendering of text"
url="https://www.pango.org/"
arch="all"
license="LGPL-2.1-or-later"
depends_dev="pango-tools=$pkgver-r$pkgrel"
-makedepends="meson cairo-dev expat-dev gobject-introspection-dev help2man
- fontconfig-dev glib-dev harfbuzz-dev libxft-dev fribidi-dev
- gtk-doc"
-checkdepends="ttf-dejavu ttf-cantarell ttf-droid ttf-tlwg"
+makedepends="
+ cairo-dev
+ expat-dev
+ fontconfig-dev
+ fribidi-dev
+ glib-dev
+ gobject-introspection-dev
+ gtk-doc
+ harfbuzz-dev
+ help2man
+ libxft-dev
+ meson
+ "
+checkdepends="font-dejavu font-cantarell font-droid font-tlwg"
install="$pkgname.pre-deinstall"
triggers="$pkgname.trigger=/usr/lib/pango/*/modules"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-tools"
@@ -26,14 +37,15 @@ source="https://download.gnome.org/sources/pango/${pkgver%.*}/pango-$pkgver.tar.
build() {
abuild-meson \
+ -Db_lto=true \
-Dintrospection=enabled \
-Dgtk_doc=false \
build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
@@ -42,11 +54,11 @@ package() {
tools() {
pkgdesc="$pkgdesc (tools)"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
+
+ amove usr/bin
}
sha512sums="
-4d754ed753fc34074c2a8751459406af7eb1eccb227c6158287f7e2921614d918cae47d078d4a2b4c098b641e40274e81bf1ec6b6a1b147efd550626665767d3 pango-1.50.7.tar.xz
-3623ef34e08427c70b4f2f89eefe13258646a935c450d9ad703c30018343aef245749e6a3708f299fd696d9f1ec0eeab116131e51918fc1765f61545202aaab0 disable-broken-test.patch
+6b3d762d133e7c900c6dfa85f43c950699930f6149cb3c90bf0e787f1b5a126a0b90220b90e649f84e4c244e44c46d4b575d5d7afeb305232c333712effc0981 pango-1.52.2.tar.xz
+b347c5dcdbe2a19f1d801193a3d309d3c14ff8474759b3ec74cc7d4714a3ac6aacce8b4ae770ba5172524a7be5654820839c5edd689d3957a2b55fedc875a5fb disable-broken-test.patch
"