aboutsummaryrefslogtreecommitdiffstats
path: root/main/paxctl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/paxctl/APKBUILD')
-rw-r--r--main/paxctl/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/paxctl/APKBUILD b/main/paxctl/APKBUILD
new file mode 100644
index 00000000000..b8ac414d76a
--- /dev/null
+++ b/main/paxctl/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=paxctl
+pkgver=0.5
+pkgrel=0
+pkgdesc="Manage PaX releated program header flags"
+url="http://pax.grsecurity.net"
+license="GPL-2"
+depends=""
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="http://pax.grsecurity.net/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's:--owner:-o:g; s:--group:-g:g; s:--mode:-m:g' Makefile
+
+ make CFLAGS="$CFLAGS" LDFLASG="$LDFLAGS" || return 1
+ make DESTDIR="$pkgdir" install
+
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="6ec138522977dc7654d33ddbe32755f0 paxctl-0.5.tar.gz"