aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-authen-sasl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-authen-sasl/APKBUILD')
-rw-r--r--main/perl-authen-sasl/APKBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/main/perl-authen-sasl/APKBUILD b/main/perl-authen-sasl/APKBUILD
index e4bf16615db..b732c186b5e 100644
--- a/main/perl-authen-sasl/APKBUILD
+++ b/main/perl-authen-sasl/APKBUILD
@@ -1,37 +1,35 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-authen-sasl
-_realname=Authen-SASL
-pkgver=2.16
-pkgrel=1
+_pkgreal=Authen-SASL
+pkgver=2.1700
+pkgrel=0
pkgdesc="SASL Authentication framework for perl"
-url="http://search.cpan.org/dist/Authen-SASL/"
+url="https://metacpan.org/release/Authen-SASL"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-digest-hmac"
-makedepends="perl-dev perl-module-install"
-install=
+makedepends="perl-module-install"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/Authen-SASL-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/E/EH/EHUELS/Authen-SASL-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}
-sha512sums="d472b8b07b8915e65a219c0a40a7b6f25ca4fb767df301f426224b8f6ebf24d66fcb4422a1f421c39631e84585af06f6c64e41abe11e1e505d03e43a9f86bd6f Authen-SASL-2.16.tar.gz"
+sha512sums="
+f2b7bef711535b2f11f2c75948c83df0d73cb830ecf101ecd36bc7435bf27677a526b5530e314798805d8a6c5be922909436ba2c9b84abedf7f36d2aa3e0727a Authen-SASL-2.1700.tar.gz
+"