aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-common-sense/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-common-sense/APKBUILD')
-rw-r--r--main/perl-common-sense/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/main/perl-common-sense/APKBUILD b/main/perl-common-sense/APKBUILD
index 0998c3f45b2..dda6a3d85dc 100644
--- a/main/perl-common-sense/APKBUILD
+++ b/main/perl-common-sense/APKBUILD
@@ -1,25 +1,28 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Contributor:
+# Automatically generated by apkbuild-cpan, template 3
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=perl-common-sense
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=common-sense
pkgver=3.75
-pkgrel=1
-pkgdesc="Implementation of sane defaults for Perl programs"
-url="https://metacpan.org/release/common-sense"
+pkgrel=4
+pkgdesc="Perl module for common-sense"
+url="https://metacpan.org/release/common-sense/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/common-sense-$pkgver.tar.gz"
-
-builddir="$srcdir"/$_pkgreal-$pkgver
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
@@ -28,4 +31,6 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="cb6034d9ff721a4122e0215db8ad5279ec4b189c3364593d427d70a1e84a1583a0e1447e276aa9a4fcaeb2f9d47a465a5bc4c0f842c803d3ddf91755311f4af4 common-sense-3.75.tar.gz"
+sha512sums="
+cb6034d9ff721a4122e0215db8ad5279ec4b189c3364593d427d70a1e84a1583a0e1447e276aa9a4fcaeb2f9d47a465a5bc4c0f842c803d3ddf91755311f4af4 common-sense-3.75.tar.gz
+"