aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-common-sense
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-common-sense')
-rw-r--r--main/perl-common-sense/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/perl-common-sense/APKBUILD b/main/perl-common-sense/APKBUILD
new file mode 100644
index 00000000000..fcf4414a06c
--- /dev/null
+++ b/main/perl-common-sense/APKBUILD
@@ -0,0 +1,31 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor:
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=perl-common-sense
+_pkgreal=common-sense
+pkgver=3.74
+pkgrel=2
+pkgdesc="Implementation of sane defaults for Perl programs"
+url="https://metacpan.org/release/common-sense"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/common-sense-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+build() {
+ perl Makefile.PL INSTALLDIRS=vendor
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="658ad70a2d1bbd0b26f91c4ea5d69b4cc0b632ede9532b88282987002a5e280f0475d63ee846b7bd2d38ef82f2680e20c2093803e4b62a984750ed447f318d60 common-sense-3.74.tar.gz"