aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-cpanel-json-xs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-cpanel-json-xs/APKBUILD')
-rw-r--r--main/perl-cpanel-json-xs/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/main/perl-cpanel-json-xs/APKBUILD b/main/perl-cpanel-json-xs/APKBUILD
index d9898e8b808..8f5f99e46d3 100644
--- a/main/perl-cpanel-json-xs/APKBUILD
+++ b/main/perl-cpanel-json-xs/APKBUILD
@@ -2,19 +2,17 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-cpanel-json-xs
_pkgreal=Cpanel-JSON-XS
-pkgver=4.12
-pkgrel=1
+pkgver=4.13
+pkgrel=0
pkgdesc="JSON::XS for Cpanel, fast and correct serialising, also for 5.6.2"
-url="http://search.cpan.org/dist/Cpanel-JSON-XS/"
+url="https://metacpan.org/release/Cpanel-JSON-XS"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpanmakedepends="perl-json perl-test-leaktrace"
-depends="$cpandepends"
+depends="perl"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/R/RU/RURBAN/Cpanel-JSON-XS-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
check() {
@@ -24,13 +22,13 @@ check() {
prepare() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
@@ -40,4 +38,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="8545095726d833d7404e8fc2a6e71a4f4b8e6c2f5d7d9939758bb8eb1ffcf33f28867a8e70fb1df995ec6c14eccde53c5c85fb6d3da2929337b15905d4195c5b Cpanel-JSON-XS-4.12.tar.gz"
+sha512sums="02aeda7488fd4fc4309502a2df14f515c2f02be4e1de62c0a67af81c486d8a820a81d4f23f1d6060a3b0265556ea96ba4d43ba47c2c8dc99ca68d511123b7196 Cpanel-JSON-XS-4.13.tar.gz"