aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-datetime-format-mail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-datetime-format-mail/APKBUILD')
-rw-r--r--main/perl-datetime-format-mail/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/perl-datetime-format-mail/APKBUILD b/main/perl-datetime-format-mail/APKBUILD
index 79edaf81019..37862306528 100644
--- a/main/perl-datetime-format-mail/APKBUILD
+++ b/main/perl-datetime-format-mail/APKBUILD
@@ -2,32 +2,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-datetime-format-mail
pkgver=0.403
-pkgrel=2
+pkgrel=4
pkgdesc="DateTime::Format::Mail perl module"
url="https://metacpan.org/release/DateTime-Format-Mail/"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="Artistic-1.0-Perl OR GPL-1.0-or-later"
depends="perl perl-datetime perl-params-validate"
-makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/B/BO/BOOK/DateTime-Format-Mail-$pkgver.tar.gz"
builddir="$srcdir"/DateTime-Format-Mail-$pkgver
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}