aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-datetime-format-w3cdtf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-datetime-format-w3cdtf/APKBUILD')
-rw-r--r--main/perl-datetime-format-w3cdtf/APKBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/main/perl-datetime-format-w3cdtf/APKBUILD b/main/perl-datetime-format-w3cdtf/APKBUILD
index cfe26f86617..90a4ca3b563 100644
--- a/main/perl-datetime-format-w3cdtf/APKBUILD
+++ b/main/perl-datetime-format-w3cdtf/APKBUILD
@@ -1,39 +1,31 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-datetime-format-w3cdtf
-pkgver=0.07
-pkgrel=1
+pkgver=0.08
+pkgrel=4
pkgdesc="DateTime::Format::W3CDTF perl module"
url="https://metacpan.org/release/DateTime-Format-W3CDTF/"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="Artistic-1.0-Perl OR GPL-1.0-or-later"
depends="perl perl-datetime"
-makedepends="perl-dev"
-install=""
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/G/GW/GWILLIAMS/DateTime-Format-W3CDTF-$pkgver.tar.gz"
+builddir="$srcdir"/DateTime-Format-W3CDTF-$pkgver
-_builddir="$srcdir"/DateTime-Format-W3CDTF-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+check() {
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="f5b8f3437c4e9a7e192900af16e83a567889dbdf1a934d604461c5096c271b497cda9bd4f9359658f536d262232e4521519f92c06bf07712922403baf6429c64 DateTime-Format-W3CDTF-0.07.tar.gz"
+sha512sums="
+d7b04870909432a7a98189dc2239ec201f9132e5a5b6db5d3284351a7db31324c1451538880d215073f8fa1e0f909b99a51354e8e87d6c4cf11d90ea184c9b4e DateTime-Format-W3CDTF-0.08.tar.gz
+"