aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-datetime-locale/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-datetime-locale/APKBUILD')
-rw-r--r--main/perl-datetime-locale/APKBUILD43
1 files changed, 28 insertions, 15 deletions
diff --git a/main/perl-datetime-locale/APKBUILD b/main/perl-datetime-locale/APKBUILD
index 9f9eaaedb0a..65745e1114b 100644
--- a/main/perl-datetime-locale/APKBUILD
+++ b/main/perl-datetime-locale/APKBUILD
@@ -1,36 +1,49 @@
+# Automatically generated by apkbuild-cpan, template 4
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-datetime-locale
-pkgver=1.32
+pkgver=1.42
pkgrel=0
-pkgdesc="DateTime::Locale perl module"
-url="https://metacpan.org/release/DateTime-Locale"
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=DateTime-Locale
+pkgdesc="Localization support for DateTime.pm"
+url="https://metacpan.org/release/DateTime-Locale/"
arch="noarch"
-license="Artistic-1.0-Perl GPL-1.0-or-later"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="
- perl perl-cpan-meta-check perl-dist-checkconflicts perl-file-sharedir
- perl-file-sharedir-install perl-list-moreutils perl-namespace-autoclean perl-params-validate
- perl-params-validationcompiler perl-scalar-list-utils perl-test-fatal perl-test-requires
- perl-test-warnings
+ perl perl-dist-checkconflicts perl-file-sharedir perl-namespace-autoclean
+ perl-params-validationcompiler perl-specio
+ "
+makedepends="perl-dist-checkconflicts perl-file-sharedir-install"
+checkdepends="
+ perl-test-file-sharedir perl-ipc-system-simple perl-path-tiny perl-test2-plugin-nowarnings
+ perl-test2-suite perl-cpan-meta-check
"
-checkdepends="perl-test-file-sharedir perl-ipc-system-simple"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Locale-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/DateTime-Locale-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-builddir="$srcdir"/DateTime-Locale-$pkgver
build() {
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
make
}
check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
-}
+ # These just seem to be examples, and are available as man pages
+ rm -v "$pkgdir"/usr/share/perl5/vendor_perl/DateTime/Locale/*.pod
+}
-sha512sums="8563f7121876272b9815f5af36f77501cc89d720e0fe08a855a7c563dee6b6399a6213162c6a6f1257c7c76c30a0f3741f642947d1499876d981225c1f5a878f DateTime-Locale-1.32.tar.gz"
+sha512sums="
+12b29d3b8f4511217125efc0607f382960941759ceb9a102e3934dced2b58eb1b509c0b7b1dcbe49638586e67cc537ec065e7f2280bd3f983c28919f8bcc0ca0 DateTime-Locale-1.42.tar.gz
+"