aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-device-serialport/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-device-serialport/APKBUILD')
-rw-r--r--main/perl-device-serialport/APKBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/main/perl-device-serialport/APKBUILD b/main/perl-device-serialport/APKBUILD
index b2736728b59..d75652bbff9 100644
--- a/main/perl-device-serialport/APKBUILD
+++ b/main/perl-device-serialport/APKBUILD
@@ -1,33 +1,35 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-device-serialport
-_realname=Device-SerialPort
+_pkgreal=Device-SerialPort
pkgver=1.04
-pkgrel=15
+pkgrel=21
pkgdesc="Linux/POSIX emulation of Win32::SerialPort functions."
-url="http://search.cpan.org/~cook/"
+url="https://metacpan.org/dist/Device-SerialPort"
arch="all"
-license="GPL PerlArtistic"
+license="Artistic-1.0-Perl OR GPL-1.0-or-later"
depends="perl"
makedepends="perl-dev"
-install=
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/C/CO/COOK/$_realname-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_realname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/C/CO/COOK/Device-SerialPort-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd $_builddir
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
}
package() {
- cd $_builddir
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}
-sha512sums="4b25a7d29091322d516e0aa20693caabe95a8521b3fdc425d1c03e3312fb59a6883268db7eaf79b32586569502fb656c875dd2b6b1d7a4341d9bd6916e04ee44 Device-SerialPort-1.04.tar.gz"
+sha512sums="
+4b25a7d29091322d516e0aa20693caabe95a8521b3fdc425d1c03e3312fb59a6883268db7eaf79b32586569502fb656c875dd2b6b1d7a4341d9bd6916e04ee44 Device-SerialPort-1.04.tar.gz
+"