aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-email-date-format/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-email-date-format/APKBUILD')
-rw-r--r--main/perl-email-date-format/APKBUILD39
1 files changed, 19 insertions, 20 deletions
diff --git a/main/perl-email-date-format/APKBUILD b/main/perl-email-date-format/APKBUILD
index 9630ce8ccec..f8f1dd0a278 100644
--- a/main/perl-email-date-format/APKBUILD
+++ b/main/perl-email-date-format/APKBUILD
@@ -1,37 +1,36 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Contributor:
+# Automatically generated by apkbuild-cpan, template 3
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-email-date-format
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Email-Date-Format
-pkgver=1.005
+pkgver=1.008
pkgrel=1
pkgdesc="produce RFC 2822 date strings"
url="https://metacpan.org/release/Email-Date-Format/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" perl-capture-tiny "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Email-Date-Format-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- make && make test
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="23daefa45874211f053d05ac3c3f3c7c3a86d9b623fdcec3bd9f6f7b4c8e5ad1ac8038146bdc85cc950b21b43b0ad843f8a52ad2183d868d3a62ea96292e34ca Email-Date-Format-1.005.tar.gz"
+sha512sums="
+24c97cd3b739c2f3c298b9ec168c4614bb71b13a0106f351990443cc86506e4e121f9c647bde6f08080a876f36adeb3fcef566d87ded9bddcbec6f3191f508be Email-Date-Format-1.008.tar.gz
+"