aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-exception-class/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-exception-class/APKBUILD')
-rw-r--r--main/perl-exception-class/APKBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/main/perl-exception-class/APKBUILD b/main/perl-exception-class/APKBUILD
index 8f596b1deee..2ad0a5153df 100644
--- a/main/perl-exception-class/APKBUILD
+++ b/main/perl-exception-class/APKBUILD
@@ -1,28 +1,29 @@
-# Automatically generated by apkbuild-cpan, template 2
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-exception-class
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Exception-Class
-pkgver=1.44
-pkgrel=2
+pkgver=1.45
+pkgrel=1
pkgdesc="A module that allows you to declare real exception classes in Perl"
url="https://metacpan.org/release/Exception-Class/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-devel-stacktrace perl-class-data-inheritable"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Exception-Class-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
+build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
+check() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make
+ make test
}
package() {
@@ -30,9 +31,6 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-check() {
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make test
-}
-
-sha512sums="7ce1e488505dc3d1c6d6365b5ed523b204b93d89d205ad4cdf6c9ee9dbad1a6edc257251a365275f067479e734def56b3b21d588e978822e7714bd8a49ba6bb2 Exception-Class-1.44.tar.gz"
+sha512sums="
+8eff70c85c8f1cc9e1db2c47b5a815ef902fddd4989783b9fb7e84e3ce75776564cafddd3aedd2c86a5a8b9627021c9cfd094b95ec4956a60dd6703bba3eaf4d Exception-Class-1.45.tar.gz
+"