aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-file-listing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-file-listing/APKBUILD')
-rw-r--r--main/perl-file-listing/APKBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/main/perl-file-listing/APKBUILD b/main/perl-file-listing/APKBUILD
index 88c765a7985..c0081b97787 100644
--- a/main/perl-file-listing/APKBUILD
+++ b/main/perl-file-listing/APKBUILD
@@ -1,36 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-file-listing
-pkgver=6.04
-pkgrel=2
-pkgdesc="File::Listing perl module"
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=File-Listing
+pkgver=6.16
+pkgrel=0
+pkgdesc="Parse directory listing"
+replaces="perl-libwww"
url="https://metacpan.org/release/File-Listing/"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-http-date"
-makedepends="perl-dev"
-install=""
-replaces="perl-libwww"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/G/GA/GAAS/File-Listing-$pkgver.tar.gz"
-
-builddir="$srcdir"/File-Listing-$pkgver
+source="https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/File-Listing-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="a84198bc82003daaf88ed23218e34a7a1552dcd2855a9563e9609ce5df167a8295043501534c31614854fc8dd9c04b4af27b4d7320112c613914f94c86c2eeb2 File-Listing-6.04.tar.gz"
+sha512sums="
+2d18f0cf7dbf30bb752c5d70132e90dd346e6fb795cb61664b8f11bfba67ec357235f5cb5a87752cf65ba9d000a6c7976548f0aed0f833048ca1b06aed991eca File-Listing-6.16.tar.gz
+"