aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-file-which/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-file-which/APKBUILD')
-rw-r--r--main/perl-file-which/APKBUILD41
1 files changed, 19 insertions, 22 deletions
diff --git a/main/perl-file-which/APKBUILD b/main/perl-file-which/APKBUILD
index d5cc1f24658..d648dfe609c 100644
--- a/main/perl-file-which/APKBUILD
+++ b/main/perl-file-which/APKBUILD
@@ -1,39 +1,36 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-file-which
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=File-Which
-pkgver=1.23
-pkgrel=2
+pkgver=1.27
+pkgrel=1
pkgdesc="Perl implementation of the which utility as an API"
url="https://metacpan.org/release/File-Which/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/File-Which-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="73c48642f448abdab2a3cf39409db50bb311cbd7ea352f5dc70f6e97296d9b09ab7e1738482864aa7f7e300a8f74b19b7ca9949fe3102f61e08fe08c9be2a4ac File-Which-1.23.tar.gz"
+sha512sums="
+8a6164c4af915e93924b1d62864e492b1c5067856e505c50b9a5cce0600d73bdcda5f7e35a9f37134d9e89949b45bbd0a5426cb56121604aea1a3cfe48d55e5c File-Which-1.27.tar.gz
+"