aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-future/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-future/APKBUILD')
-rw-r--r--main/perl-future/APKBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/main/perl-future/APKBUILD b/main/perl-future/APKBUILD
index d34cfb4d93c..e547accbe81 100644
--- a/main/perl-future/APKBUILD
+++ b/main/perl-future/APKBUILD
@@ -1,29 +1,24 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-future
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Future
-pkgver=0.47
-pkgrel=0
+pkgver=0.50
+pkgrel=1
pkgdesc="represent an operation awaiting completion"
-url="https://metacpan.org/release/Future"
+url="https://metacpan.org/release/Future/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
-makedepends="perl-module-build"
-checkdepends="perl-test-refcount perl-test-fatal perl-test-identity"
+makedepends="perl-dev perl-module-build"
+checkdepends="perl-test2-suite"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Future-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- perl Build.PL installdirs=vendor
-}
-
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
./Build
}
@@ -32,9 +27,10 @@ check() {
}
package() {
- ./Build install destdir="$pkgdir"
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-
-sha512sums="d3cdd7409be0768ac0787945746e1ea217f02e84bc04b6309c532451a9193fbdc005b3c4de37d31751e6a806649d08028c93c3bfd24df6d6d2c2bf042b01d814 Future-0.47.tar.gz"
+sha512sums="
+d8c0011d0dcee9bb0317a394da34925d6a5e214ff8706158268d546f5b0e6d8fad7a8edafda2eada15bcca20d2da9ae722018c6dd0ff9a69bae1c0759776f616 Future-0.50.tar.gz
+"