aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-html-quoted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-html-quoted/APKBUILD')
-rw-r--r--main/perl-html-quoted/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/main/perl-html-quoted/APKBUILD b/main/perl-html-quoted/APKBUILD
index 5173a43b6f2..b977de3f3ba 100644
--- a/main/perl-html-quoted/APKBUILD
+++ b/main/perl-html-quoted/APKBUILD
@@ -8,25 +8,22 @@ url="https://metacpan.org/release/HTML-Quoted/"
arch="noarch"
license="GPL-2.0 or Artistic"
depends="perl perl-html-parser"
-makedepends="perl-dev perl-module-install"
+makedepends="perl-module-install"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/T/TS/TSIBLEY/HTML-Quoted-$pkgver.tar.gz"
builddir="$srcdir/HTML-Quoted-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}